summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-18 21:47:17 +0000
committerSam James <sam@gentoo.org>2024-11-23 16:07:48 +0000
commitbab2378af620dcf5d1eb534b6e39f518d80f32f7 (patch)
tree5a8efaf4e2b79987be19c8a153c9b7458b9262c4 /dev-cpp
parentsci-libs/opencascade: remove jemalloc from metadata as it's global (diff)
downloadgentoo-bab2378af620dcf5d1eb534b6e39f518d80f32f7.tar.gz
gentoo-bab2378af620dcf5d1eb534b6e39f518d80f32f7.tar.bz2
gentoo-bab2378af620dcf5d1eb534b6e39f518d80f32f7.zip
dev-cpp/mvfst: use the correct CMake variables
For some reason these are different than most of the Facebook C++ libraries. Closes: https://bugs.gentoo.org/943625 Signed-off-by: sin-ack <sin-ack@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/39365 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild (renamed from dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild)4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild b/dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild
index 12d43e1df1c3..396d42d484be 100644
--- a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
+++ b/dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild
@@ -40,8 +40,8 @@ DEPEND="
src_configure() {
local mycmakeargs=(
- -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
- -DLIB_INSTALL_DIR="$(get_libdir)"
+ -DCMAKE_INSTALL_MODULE_DIR="$(get_libdir)/cmake/${PN}"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
-DBUILD_TESTS="$(usex test ON OFF)"
)