summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.2.ebuild')
-rw-r--r--dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.2.ebuild115
1 files changed, 115 insertions, 0 deletions
diff --git a/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.2.ebuild b/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.2.ebuild
new file mode 100644
index 000000000000..372e20ef1f64
--- /dev/null
+++ b/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib
+
+MY_P_x86="${PN/oracle-/}-linux32-${PV}.0"
+MY_PSDK_x86="${MY_P_x86/basic/sdk}"
+
+MY_PBASE_amd64="${PN/oracle-instantclient-basic/instantclient-basic-linux}-x86-64-${PV}.0"
+MY_P_amd64="${PN/oracle-instantclient-basic/instantclient-basic-linux}-x86-64-${PV}.0"
+MY_PSDK_amd64="${MY_PBASE_amd64/basic/sdk}"
+
+DESCRIPTION="Oracle 11g client installation for Linux with SDK"
+HOMEPAGE="http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html"
+SRC_URI="x86? ( ${MY_P_x86}.zip ${MY_PSDK_x86}.zip )
+ amd64? ( ${MY_P_amd64}.zip ${MY_PSDK_amd64}.zip )"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+RESTRICT="fetch"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/libaio"
+
+S="${WORKDIR}"
+
+my_arch() {
+ MY_P=MY_P_${ARCH}
+ export MY_P=${!MY_P}
+ MY_PSDK=MY_PSDK_${ARCH}
+ export MY_PSDK=${!MY_PSDK}
+}
+
+pkg_setup() {
+ my_arch
+}
+
+pkg_nofetch() {
+ my_arch
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "select your platform and download the"
+ eerror "Basic client package with SDK, which are:"
+ eerror " ${MY_P}.zip"
+ eerror " ${MY_PSDK}.zip"
+ eerror "Then after downloading put them in:"
+ eerror " ${DISTDIR}"
+}
+
+src_unpack() {
+ unzip "${DISTDIR}"/${MY_P}.zip || die "unsuccesful unzip ${MY_P}.zip"
+ unzip "${DISTDIR}"/${MY_PSDK}.zip || die "unsuccesful unzip ${MY_PSDK}.zip"
+}
+
+src_install() {
+ # SDK makefile
+ dodir /usr/$(get_libdir)/oracle/${PV}/client/rdbms/demo
+ cd "${S}"/instantclient_11_2/sdk/demo
+ mv demo.mk demo_xe.mk
+ insinto /usr/$(get_libdir)/oracle/${PV}/client/rdbms/demo
+ doins demo_xe.mk
+
+ # library
+ dodir /usr/$(get_libdir)/oracle/${PV}/client/lib
+ cd "${S}"/instantclient_11_2
+ insinto /usr/$(get_libdir)/oracle/${PV}/client/lib
+ doins *.jar *.so *.so.11.1
+
+ # fixes symlinks
+ dosym /usr/$(get_libdir)/oracle/${PV}/client/lib/libocci.so.11.1 /usr/$(get_libdir)/oracle/${PV}/client/lib/libocci.so
+ dosym /usr/$(get_libdir)/oracle/${PV}/client/lib/libclntsh.so.11.1 /usr/$(get_libdir)/oracle/${PV}/client/lib/libclntsh.so
+ dosym /usr/$(get_libdir)/oracle/${PV}/client/include /usr/$(get_libdir)/oracle/${PV}/client/rdbms/public
+
+ # includes
+ dodir /usr/$(get_libdir)/oracle/${PV}/client/include
+ insinto /usr/$(get_libdir)/oracle/${PV}/client/include
+ cd "${S}"/instantclient_11_2/sdk/include
+ # Remove ldap.h, #299562
+ rm ldap.h || die "rm failed"
+ doins *.h
+ # link to original location
+ dodir /usr/include/oracle/${PV}/
+ ln -s "${D}"/usr/$(get_libdir)/oracle/${PV}/client/include "${D}"/usr/include/oracle/${PV}/client
+
+ # share info
+ cd "${S}"/instantclient_11_2/sdk/demo
+ dodoc *
+
+ # Add OCI libs to library path
+ dodir /etc/env.d
+ echo "ORACLE_HOME=/usr/$(get_libdir)/oracle/${PV}/client" >> "${D}"/etc/env.d/50oracle-instantclient-basic
+ echo "LDPATH=/usr/$(get_libdir)/oracle/${PV}/client/lib" >> "${D}"/etc/env.d/50oracle-instantclient-basic
+ echo "C_INCLUDE_PATH=/usr/$(get_libdir)/oracle/${PV}/client/include" >> "${D}"/etc/env.d/50oracle-instantclient-basic
+ echo "TNS_ADMIN=/etc/oracle/" >> "${D}"/etc/env.d/50oracle-instantclient-basic
+
+ # create path for tnsnames.ora
+ dodir /etc/oracle
+}
+
+pkg_postinst() {
+ elog "The Basic client package for Oracle 11g has been installed."
+ elog "You may also wish to install the oracle-instantclient-jdbc (for"
+ elog "supplemental JDBC functionality with Oracle) and the"
+ elog "oracle-instantclient-sqlplus (for running the SQL*Plus application)"
+ elog "packages as well."
+ elog
+ elog "Examples are located in /usr/share/doc/${PF}/"
+ elog
+ elog "TNS_ADMIN has been set to "${ROOT}"etc/oracle by default, put your"
+ elog "tnsnames.ora there or configure TNS_ADMIN to point to"
+ elog "your user specific configuration."
+}