summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-13 15:07:35 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-13 15:07:35 -0400
commit099885d492e52d178f6d8b6bb27e747f83d29b65 (patch)
tree97e8e301e68accad694dc17d5af6158933022dac /dev-db/postgresql/postgresql-9999.ebuild
parentsys-apps/nix: bump up to 1.11.12 (diff)
downloadgentoo-099885d492e52d178f6d8b6bb27e747f83d29b65.tar.gz
gentoo-099885d492e52d178f6d8b6bb27e747f83d29b65.tar.bz2
gentoo-099885d492e52d178f6d8b6bb27e747f83d29b65.zip
dev-db/postgresql: Spinlocks, pushd, and man
All versions now generate slotted man pages instead of using symlinks. This is cleaner, and won’t result in broken links. You can now run ‘man psql96’ (or similar) and actually get the man page for psql, version 9.6.x. 10_beta2 and 9999 now dies if it can’t pushd into the directory it needs to be in when generating the man pages. Re-disabled spinlocks for versions 9.5 and after. Somehow this got excluded from the 9.6 release. Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-db/postgresql/postgresql-9999.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index 0245d247103d..6c6a2cb39462 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -213,7 +213,7 @@ src_install() {
local rel_manpath="../../postgresql-${SLOT}/man/man${mansec}"
mkdir -p "${ED}"/usr/share/man/man${mansec} || die "making man dir"
- pushd "${ED}"/usr/share/man/man${mansec} > /dev/null
+ pushd "${ED}"/usr/share/man/man${mansec} > /dev/null || die "pushd failed"
for f in "${ED}/usr/share/postgresql-${SLOT}/man/man${mansec}"/* ; do
bn=$(basename "${f}")