summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJon Janzen <jon@jonjanzen.com>2023-05-13 14:02:44 -0700
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-12 16:02:33 +0200
commit1baf22c073b3dabbf798c038fbf081afdaa94b95 (patch)
tree0c136de72a6671c6fb154c340f2887c70f6073c0 /dev-db
parentsci-geosciences/librttopo: new package, add 1.1.0 (diff)
downloadgentoo-1baf22c073b3dabbf798c038fbf081afdaa94b95.tar.gz
gentoo-1baf22c073b3dabbf798c038fbf081afdaa94b95.tar.bz2
gentoo-1baf22c073b3dabbf798c038fbf081afdaa94b95.zip
dev-db/spatialite: Add support for librttopo
Signed-off-by: Jon Janzen <jon@jonjanzen.com> Closes: https://github.com/gentoo/gentoo/pull/31027 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/spatialite/metadata.xml1
-rw-r--r--dev-db/spatialite/spatialite-5.0.1-r2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-db/spatialite/metadata.xml b/dev-db/spatialite/metadata.xml
index 3d4b1b79db43..8ca3a8f8ce3f 100644
--- a/dev-db/spatialite/metadata.xml
+++ b/dev-db/spatialite/metadata.xml
@@ -9,5 +9,6 @@
<flag name="geos">Add the <pkg>sci-libs/geos</pkg> library for exact topological tests</flag>
<flag name="proj">Add the <pkg>sci-libs/proj</pkg> library for reprojection features</flag>
<flag name="xls">Add the <pkg>dev-libs/freexl</pkg> library for xls import support</flag>
+ <flag name="rttopo">Add the <pkg>sci-geosciences/librttopo</pkg> library for topology support</flag>
</use>
</pkgmetadata>
diff --git a/dev-db/spatialite/spatialite-5.0.1-r2.ebuild b/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
new file mode 100644
index 000000000000..9e9e02eba1df
--- /dev/null
+++ b/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="lib${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
+HOMEPAGE="https://www.gaia-gis.it/gaia-sins/"
+SRC_URI="https://www.gaia-gis.it/gaia-sins/${MY_PN}-sources/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+geos iconv +proj rttopo test +xls +xml"
+# Further poking required
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-db/sqlite-3.7.5:3[extensions(+)]
+ sys-libs/zlib[minizip]
+ geos? ( >=sci-libs/geos-3.4 )
+ proj? ( sci-libs/proj:= )
+ xls? ( dev-libs/freexl )
+ xml? ( dev-libs/libxml2 )
+ rttopo? ( sci-geosciences/librttopo )
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="test? ( iconv )"
+
+src_configure() {
+ # 1) gcp disabled for now to preserve MPL licence
+ econf \
+ --disable-gcp \
+ --disable-examples \
+ --disable-static \
+ --enable-epsg \
+ --enable-geocallbacks \
+ $(use_enable rttopo) \
+ $(use_enable geos) \
+ $(use_enable geos geosadvanced) \
+ $(use_enable iconv) \
+ $(use_enable proj) \
+ $(use_enable xls freexl) \
+ $(use_enable xml libxml2)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}