summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2023-09-19 08:44:30 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2023-09-19 08:45:54 -0400
commit7d19efc5363478abe880f136aa296c7926cb3532 (patch)
treec48424996d2c29486f629f82a6c27c33ba7ee4f3 /dev-db
parentmedia-gfx/ueberzugpp: add 2.9.2 (diff)
downloadgentoo-7d19efc5363478abe880f136aa296c7926cb3532.tar.gz
gentoo-7d19efc5363478abe880f136aa296c7926cb3532.tar.bz2
gentoo-7d19efc5363478abe880f136aa296c7926cb3532.zip
dev-db/postgresql: Drop threads use flag
Closes: https://bugs.gentoo.org/868393 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/postgresql-11.21.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-12.16.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-13.12.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-14.9.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-15.4.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-16.0.ebuild7
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild6
7 files changed, 15 insertions, 28 deletions
diff --git a/dev-db/postgresql/postgresql-11.21.ebuild b/dev-db/postgresql/postgresql-11.21.ebuild
index 052d6c8aee36..13390d4be799 100644
--- a/dev-db/postgresql/postgresql-11.21.ebuild
+++ b/dev-db/postgresql/postgresql-11.21.ebuild
@@ -21,9 +21,8 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug doc icu kerberos ldap llvm nls pam
- perl python +readline selinux +server systemd ssl static-libs tcl
- threads uuid xml zlib"
+IUSE="debug doc icu kerberos ldap llvm nls pam perl python +readline
+ selinux +server systemd ssl static-libs tcl uuid xml zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -141,7 +140,6 @@ src_configure() {
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
$(use_enable !alpha spinlocks) \
$(use_enable debug) \
- $(use_enable threads thread-safety) \
$(use_with icu) \
$(use_with kerberos gssapi) \
$(use_with ldap) \
diff --git a/dev-db/postgresql/postgresql-12.16.ebuild b/dev-db/postgresql/postgresql-12.16.ebuild
index b55c3b2a3cbf..382ca7191482 100644
--- a/dev-db/postgresql/postgresql-12.16.ebuild
+++ b/dev-db/postgresql/postgresql-12.16.ebuild
@@ -21,9 +21,8 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug doc icu kerberos ldap llvm nls pam
- perl python +readline selinux +server systemd ssl static-libs tcl
- threads uuid xml zlib"
+IUSE="debug doc icu kerberos ldap llvm nls pam perl python +readline
+ selinux +server systemd ssl static-libs tcl uuid xml zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -141,7 +140,6 @@ src_configure() {
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
$(use_enable !alpha spinlocks) \
$(use_enable debug) \
- $(use_enable threads thread-safety) \
$(use_with icu) \
$(use_with kerberos gssapi) \
$(use_with ldap) \
diff --git a/dev-db/postgresql/postgresql-13.12.ebuild b/dev-db/postgresql/postgresql-13.12.ebuild
index 97f75c5fa8a1..5da40dbc3de5 100644
--- a/dev-db/postgresql/postgresql-13.12.ebuild
+++ b/dev-db/postgresql/postgresql-13.12.ebuild
@@ -21,9 +21,8 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug doc icu kerberos ldap llvm nls pam
- perl python +readline selinux +server systemd ssl static-libs tcl
- threads uuid xml zlib"
+IUSE="debug doc icu kerberos ldap llvm nls pam perl python +readline
+ selinux +server systemd ssl static-libs tcl uuid xml zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -142,7 +141,6 @@ src_configure() {
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
$(use_enable debug) \
- $(use_enable threads thread-safety) \
$(use_with icu) \
$(use_with kerberos gssapi) \
$(use_with ldap) \
diff --git a/dev-db/postgresql/postgresql-14.9.ebuild b/dev-db/postgresql/postgresql-14.9.ebuild
index 85a0a1e068c2..11f0bdf2b513 100644
--- a/dev-db/postgresql/postgresql-14.9.ebuild
+++ b/dev-db/postgresql/postgresql-14.9.ebuild
@@ -21,9 +21,8 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug doc icu kerberos ldap llvm lz4 nls pam
- perl python +readline selinux +server systemd ssl static-libs tcl
- threads uuid xml zlib"
+IUSE="debug doc icu kerberos ldap llvm lz4 nls pam perl python +readline
+ selinux +server systemd ssl static-libs tcl uuid xml zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -141,7 +140,6 @@ src_configure() {
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
$(use_enable debug) \
- $(use_enable threads thread-safety) \
$(use_with icu) \
$(use_with kerberos gssapi) \
$(use_with ldap) \
diff --git a/dev-db/postgresql/postgresql-15.4.ebuild b/dev-db/postgresql/postgresql-15.4.ebuild
index bb65bd3a81e7..512aa08d2e60 100644
--- a/dev-db/postgresql/postgresql-15.4.ebuild
+++ b/dev-db/postgresql/postgresql-15.4.ebuild
@@ -21,9 +21,8 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug doc icu kerberos ldap llvm lz4 nls pam
- perl python +readline selinux +server systemd ssl static-libs tcl
- threads uuid xml zlib zstd"
+IUSE="debug doc icu kerberos ldap llvm lz4 nls pam perl python +readline
+ selinux +server systemd ssl static-libs tcl uuid xml zlib zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -142,7 +141,6 @@ src_configure() {
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
$(use_enable debug) \
- $(use_enable threads thread-safety) \
$(use_with icu) \
$(use_with kerberos gssapi) \
$(use_with ldap) \
diff --git a/dev-db/postgresql/postgresql-16.0.ebuild b/dev-db/postgresql/postgresql-16.0.ebuild
index 118da5e30607..63bb54fd4eb4 100644
--- a/dev-db/postgresql/postgresql-16.0.ebuild
+++ b/dev-db/postgresql/postgresql-16.0.ebuild
@@ -21,9 +21,9 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug doc +icu kerberos ldap llvm lz4 nls pam
- perl python +readline selinux +server systemd ssl static-libs tcl
- threads uuid xml zlib zstd"
+IUSE="debug doc +icu kerberos ldap llvm lz4 nls pam perl python
+ +readline selinux +server systemd ssl static-libs tcl uuid xml
+ zlib zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -142,7 +142,6 @@ src_configure() {
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
$(use_enable debug) \
- $(use_enable threads thread-safety) \
$(use_with icu) \
$(use_with kerberos gssapi) \
$(use_with ldap) \
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index 322fa8316357..ff52cfb7a800 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -17,9 +17,8 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug +icu kerberos ldap llvm +lz4
- nls pam perl python +readline selinux server systemd
- ssl static-libs tcl threads uuid xml zlib zstd"
+IUSE="debug +icu kerberos ldap llvm +lz4 nls pam perl python +readline
+ selinux server systemd ssl static-libs tcl uuid xml zlib zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -155,7 +154,6 @@ src_configure() {
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
$(use_enable debug) \
$(use_enable nls) \
- $(use_enable threads thread-safety) \
$(use_with icu) \
$(use_with kerberos gssapi) \
$(use_with ldap) \