summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-01-19 13:22:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-01-19 13:24:44 +0000
commit9a8438f6717e506db4af00c80cbe098e2e44a5ef (patch)
treec9df38f6218db65858246ebd8979edcb29144b96 /dev-db
parentmate-base/mate-applets: restore USE=ipv6 (diff)
downloadgentoo-9a8438f6717e506db4af00c80cbe098e2e44a5ef.tar.gz
gentoo-9a8438f6717e506db4af00c80cbe098e2e44a5ef.tar.bz2
gentoo-9a8438f6717e506db4af00c80cbe098e2e44a5ef.zip
dev-db/plr: add 8.4.6
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/plr/Manifest1
-rw-r--r--dev-db/plr/plr-8.4.6.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-db/plr/Manifest b/dev-db/plr/Manifest
index 6b8423543b46..e3e94a94bb3c 100644
--- a/dev-db/plr/Manifest
+++ b/dev-db/plr/Manifest
@@ -1 +1,2 @@
DIST plr-8.4.5.tar.gz 273711 BLAKE2B 666941f1cbc7e74dee532b928102afda4684b344f3c69a6ac4e3449c057e8f4dbb74b765f4222bb06e61940fa1e4ba888cc60bac193ca43989b557da9d02ceaa SHA512 bb04a8956d1cdc7acb20c89ea3b17be6ee385dac52381ab0f8af7446480fa9b8d163ff6697a05b439a75f57841b203e65bea78db8a7c3d55c1118bebbf4ac81a
+DIST plr-8.4.6.tar.gz 277578 BLAKE2B 575426e44e553f52dfe9b4bd1eb8de1b72e9023abe086c6b1570dabcda1b5e99a8eebce9c5b0e97019aec969b369e15a83801d51b8531695026e1a9bdc79d5c0 SHA512 de5f6b094f4eb6f88df6134142c461bc4ebd6a692c3db03cf04e1d0f04b71d63a26bce22defc1f25fa627c7bc4ba63c533dd2df1f571b58cb04d29c7eada2e42
diff --git a/dev-db/plr/plr-8.4.6.ebuild b/dev-db/plr/plr-8.4.6.ebuild
new file mode 100644
index 000000000000..bb10bae54f14
--- /dev/null
+++ b/dev-db/plr/plr-8.4.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( {12..16} )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="R language extension for postgresql database"
+HOMEPAGE="http://www.joeconway.com/plr/"
+SRC_URI="https://github.com/postgres-plr/plr/archive/REL${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-lang/R
+ ${POSTGRES_DEP}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+S="${WORKDIR}"/contrib/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ # the build system wants 'contrib' to be part of the path
+ mkdir -p "${WORKDIR}/contrib" || die
+ mv "${WORKDIR}/${PN}-REL${PV//./_}" "${S}" || die
+}
+
+src_prepare() {
+ local BUILD_DIR="${S}"
+ postgres-multi_src_prepare
+}
+
+src_compile() {
+ pg_src_compile() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${ESYSROOT}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1
+ }
+ postgres-multi_foreach pg_src_compile
+}
+
+src_install() {
+ pg_src_install() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${ESYSROOT}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1 DESTDIR="${D}" install
+ }
+ postgres-multi_foreach pg_src_install
+}
+
+pkg_postinst() {
+ elog "The plr extension needs to be explicitly added (or 'created') on each database"
+ elog "you wish to use it with. As of postgresql-9.1 the easiest way to do this is"
+ elog "with the proprietary SQL statement:"
+ elog
+ elog "\tCREATE EXTENSION plr;"
+ elog
+ elog "For more info on how to add PL/R to your postgresql database(s), please visit"
+ elog "http://www.joeconway.com/doc/plr-install.html"
+}