summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-11-16 10:26:57 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2017-11-16 10:29:17 -0500
commitcc14b56e70570e3804910f0c566be7cc1df6d2fe (patch)
tree9985a043bae5ce433b0cdd128ade7e7bbb238970 /dev-db
parentapp-admin/logstash-bin: drop old (diff)
downloadgentoo-cc14b56e70570e3804910f0c566be7cc1df6d2fe.tar.gz
gentoo-cc14b56e70570e3804910f0c566be7cc1df6d2fe.tar.bz2
gentoo-cc14b56e70570e3804910f0c566be7cc1df6d2fe.zip
dev-db/postgis: Bump to 2.4.2
Bump version to 2.4.2. Add additional USE flags to control optional dependencies. Closes: https://bugs.gentoo.org/634828 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgis/Manifest1
-rw-r--r--dev-db/postgis/metadata.xml13
-rw-r--r--dev-db/postgis/postgis-2.4.2.ebuild125
3 files changed, 138 insertions, 1 deletions
diff --git a/dev-db/postgis/Manifest b/dev-db/postgis/Manifest
index 0811dde086eb..d4cda09966f6 100644
--- a/dev-db/postgis/Manifest
+++ b/dev-db/postgis/Manifest
@@ -1,3 +1,4 @@
DIST postgis-2.1.8.tar.gz 6811272 SHA256 7c2380b895fe7bda34c2e70deab3fcf4c12b13ab40d7501cdaa6fa36f1a6c662 SHA512 e8aeb739a1ecf95b224a3908d2af3aa38933b56c63713af30d14243653745436165b418a3368601a699b744f6fe61ce645c980319eb159395d68166a3815c5f4 WHIRLPOOL b6675fecbb922379bd50c351abe1553fdbda53543fce56451c688e25a3fa2e9d0813d8f3a349b623b85fcb4016fc4710f6746a224ba7673ec0d2106c7635d3d1
DIST postgis-2.3.3.tar.gz 11342032 SHA256 723d43a1c8ca4cf06359ec0b7fd5521b355db4e37128a26fb8c661b1fe2fc930 SHA512 c0ec4b4b5c470e5f88d1bb72c528269a0cf954981385580db3333502c2da74e431b5a86e3d6427c839c3d4440122be18a69261c8205aa71c8aa4b790550c5e9c WHIRLPOOL 427d4637e0073ad549cd2e74d117b2dc2b0b0e5fff98f9a0bbee3514c00b3688dd56acd7bb3f1742eda61238cf8c5ab81cea6ead7ea5880261b753a86e0f847e
DIST postgis-2.4.0.tar.gz 12576979 SHA256 02baa90f04da41e04b6c18eedfda53110c45ae943d4e65050f6d202f7de07d29 SHA512 813e8e9feb75b58673afaec2dda3b5d8fc586a0f483c553795c8ae2b917bb67a9741e8c901787a0b914c327848323239346f1d816aa60b47d5a7065596de0067 WHIRLPOOL 75403b5d1babdc1d714d29a6c1f86dfcd1503997536d6a35333b6e19c72de44aa131cba3c6a9a4f2ced59a280eb0eaee41696fa8440c2028f8555d6a2c4dcd3b
+DIST postgis-2.4.2.tar.gz 12470881 SHA256 23625bc99ed440d53a20225721095a3f5c653b62421c4d597c8038f0d7a321d9 SHA512 e268572d5cd009754ef05f5d2eedcac7e362fa47199459c637cd4d9050d2b648d4b2b3746cde0dce5a42be2606a432b64dc905f193e12cf0869e3dd6f820b425 WHIRLPOOL 5a87b34733dce189d6a30a4ca88599467ff0987c214b258d9d873975de2f746a26281a983d8f98f9d3758da121d0adc2384c8dc1d3d247130213020cecf887f1
diff --git a/dev-db/postgis/metadata.xml b/dev-db/postgis/metadata.xml
index 41af88acdf31..079d84079f20 100644
--- a/dev-db/postgis/metadata.xml
+++ b/dev-db/postgis/metadata.xml
@@ -10,6 +10,17 @@
<name>Gentoo Geosciences Project</name>
</maintainer>
<use>
- <flag name="gtk">Build shp2pgsql-gui a graphical interface to shp2pgsql</flag>
+ <flag name="address-standardizer">
+ Normalize US and CA postal addresses
+ </flag>
+ <flag name="gtk">
+ Build graphical interface for shp2pgsql (shp2pgsql-gui)
+ </flag>
+ <flag name="mapbox">
+ Add capability to transform geometry into Mapbox Vector Tile
+ </flag>
+ <flag name="topology">
+ Build topology spatial types and functions
+ </flag>
</use>
</pkgmetadata>
diff --git a/dev-db/postgis/postgis-2.4.2.ebuild b/dev-db/postgis/postgis-2.4.2.ebuild
new file mode 100644
index 000000000000..eb28a8841e0e
--- /dev/null
+++ b/dev-db/postgis/postgis-2.4.2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+POSTGRES_COMPAT=( 9.{2..6} 10 )
+POSTGRES_USEDEP="server"
+
+inherit autotools eutils postgres-multi versionator
+
+MY_PV=$(replace_version_separator 3 '')
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="http://postgis.net"
+SRC_URI="http://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="address-standardizer doc gtk static-libs mapbox test topology"
+
+RDEPEND="
+ ${POSTGRES_DEP}
+ dev-libs/json-c
+ dev-libs/libxml2:2
+ >=sci-libs/geos-3.5.0
+ >=sci-libs/proj-4.6.0
+ >=sci-libs/gdal-1.10.0
+ address-standardizer? ( dev-libs/libpcre )
+ gtk? ( x11-libs/gtk+:2 )
+ mapbox? ( dev-libs/protobuf )
+"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/libxslt
+ || (
+ media-gfx/imagemagick[png]
+ media-gfx/graphicsmagick[imagemagick,png]
+ )
+ )
+ virtual/pkgconfig
+ test? ( dev-util/cunit )
+"
+
+PGIS="$(get_version_component_range 1-2)"
+
+REQUIRED_USE="test? ( doc ) ${POSTGRES_REQ_USE}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+MAKEOPTS+=' -j1'
+
+# These modules are built using the same *FLAGS that were used to build
+# dev-db/postgresql. The right thing to do is to ignore the current
+# *FLAGS settings.
+QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.2.0-arflags.patch"
+
+ local AT_M4DIR="macros"
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ local myargs=""
+
+ use gtk && myargs+=" --with-gui"
+
+ use address-standardizer || myargs+=" --without-address-standardizer"
+ use mapbox || myargs+=" --without-protobuf"
+ use topology || myargs+=" --without-topology"
+
+ postgres-multi_foreach econf ${myargs}
+}
+
+src_compile() {
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C topology
+
+ if use doc ; then
+ postgres-multi_foreach emake comments
+ postgres-multi_foreach emake cheatsheets
+ postgres-multi_forbest emake -C doc html
+ fi
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+ postgres-multi_foreach emake -C topology DESTDIR="${D}" install
+ postgres-multi_forbest dobin ./utils/postgis_restore.pl
+
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+
+ if use doc ; then
+ postgres-multi_foreach emake DESTDIR="${D}" comments-install
+
+ docinto html
+ postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
+
+ docinto html/images
+ postgres-multi_forbest dodoc doc/html/images/*
+ fi
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
+
+pkg_postinst() {
+ ebegin "Refreshing PostgreSQL symlinks"
+ postgresql-config update
+ eend $?
+
+ elog "To finish installing PostGIS, follow the directions detailed at:"
+ elog "http://postgis.net/docs/manual-${PGIS}/postgis_installation.html#create_new_db_extensions"
+}