summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/feed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/feed')
-rw-r--r--dev-haskell/feed/Manifest2
-rw-r--r--dev-haskell/feed/feed-0.3.9.2-r1.ebuild32
-rw-r--r--dev-haskell/feed/feed-0.3.9.2.ebuild27
-rw-r--r--dev-haskell/feed/feed-0.3.9.7.ebuild35
-rw-r--r--dev-haskell/feed/files/feed-0.3.9.2-ghc-7.10.patch20
-rw-r--r--dev-haskell/feed/files/feed-0.3.9.2-utf8-string.patch25
-rw-r--r--dev-haskell/feed/metadata.xml11
7 files changed, 152 insertions, 0 deletions
diff --git a/dev-haskell/feed/Manifest b/dev-haskell/feed/Manifest
new file mode 100644
index 000000000000..5f3662c3adc9
--- /dev/null
+++ b/dev-haskell/feed/Manifest
@@ -0,0 +1,2 @@
+DIST feed-0.3.9.2.tar.gz 73353 SHA256 ef1d23d130b766186a0bacd6e4807279cab681712b0fb09d1ed1ee1b3c154f17 SHA512 36e9d75d7bab4c26967d39a20c1b8382a24f2f5059dadf0425bbcc16a659587a842f948a456d63cb32660feb4d7d56ffdf6aead7ec5c40abb678b9fdce25ff0f WHIRLPOOL 953bda571eb1f8e8925459065e52e8759db5253f433f82427c3ff246c0ce3d3cf3c26a04a751272d216badc64677938bdf1f0fb309c9007ff8c115680036bb92
+DIST feed-0.3.9.7.tar.gz 76042 SHA256 1468425b73887fba6740ab3e64ac62473be5f5ec61de17c5e1ac8812d4f15a07 SHA512 340d0889f98c329e116a6c785752f675c565a959b787629bf6ed0b31ce9336aaa402e9a008c72c040b6f91988657381580eb5ae110a8a6b441ebacfec362824a WHIRLPOOL 764aab94d7fa4885012b29dc39116654750e04d72efdb624d1efec70be7ef133326a9422ba86cba12e4de8f103c774e58c9bb93789e50b24f0777ec4d5e6fd4e
diff --git a/dev-haskell/feed/feed-0.3.9.2-r1.ebuild b/dev-haskell/feed/feed-0.3.9.2-r1.ebuild
new file mode 100644
index 000000000000..abf0a61951fb
--- /dev/null
+++ b/dev-haskell/feed/feed-0.3.9.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds"
+HOMEPAGE="https://github.com/sof/feed"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/xml-1.2.6:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-utf8-string.patch
+ epatch "${FILESDIR}"/"${P}"-ghc-7.10.patch
+}
diff --git a/dev-haskell/feed/feed-0.3.9.2.ebuild b/dev-haskell/feed/feed-0.3.9.2.ebuild
new file mode 100644
index 000000000000..94d03643c958
--- /dev/null
+++ b/dev-haskell/feed/feed-0.3.9.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds"
+HOMEPAGE="https://github.com/sof/feed"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/xml-1.2.6:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/feed/feed-0.3.9.7.ebuild b/dev-haskell/feed/feed-0.3.9.7.ebuild
new file mode 100644
index 000000000000..440e6e48e9ab
--- /dev/null
+++ b/dev-haskell/feed/feed-0.3.9.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds"
+HOMEPAGE="https://github.com/bergmark/feed"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # slow
+
+RDEPEND=">=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/old-time-1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
+ <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/xml-1.2.6:=[profile?] <dev-haskell/xml-1.3.15:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4 )
+"
diff --git a/dev-haskell/feed/files/feed-0.3.9.2-ghc-7.10.patch b/dev-haskell/feed/files/feed-0.3.9.2-ghc-7.10.patch
new file mode 100644
index 000000000000..41f672c8f910
--- /dev/null
+++ b/dev-haskell/feed/files/feed-0.3.9.2-ghc-7.10.patch
@@ -0,0 +1,20 @@
+--- feed-0.3.9.2-orig/Text/Feed/Query.hs 2013-10-28 02:48:21.000000000 +1100
++++ feed-0.3.9.2/Text/Feed/Query.hs 2015-04-04 11:48:36.759173147 +1100
+@@ -1,3 +1,4 @@
++{-# LANGUAGE CPP #-}
+ --------------------------------------------------------------------
+ -- |
+ -- Module : Text.Feed.Query
+@@ -62,7 +63,12 @@
+ import Data.Maybe
+
+ -- for getItemPublishDate rfc822 date parsing.
++#if MIN_VERSION_time(1,5,0)
++import System.Locale ( rfc822DateFormat, iso8601DateFormat )
++import Data.Time ( defaultTimeLocale )
++#else
+ import System.Locale ( rfc822DateFormat, iso8601DateFormat, defaultTimeLocale )
++#endif
+ import Data.Time.Format ( ParseTime, parseTime )
+
+ feedItems :: Feed.Feed -> [Feed.Item]
diff --git a/dev-haskell/feed/files/feed-0.3.9.2-utf8-string.patch b/dev-haskell/feed/files/feed-0.3.9.2-utf8-string.patch
new file mode 100644
index 000000000000..323ae701cde4
--- /dev/null
+++ b/dev-haskell/feed/files/feed-0.3.9.2-utf8-string.patch
@@ -0,0 +1,25 @@
+diff --git a/Text/Feed/Import.hs b/Text/Feed/Import.hs
+index 8fde5f9..c001cee 100644
+--- a/Text/Feed/Import.hs
++++ b/Text/Feed/Import.hs
+@@ -12,6 +12,7 @@
+ --
+ --------------------------------------------------------------------
+
++{-# LANGUAGE CPP #-}
+ module Text.Feed.Import
+ ( parseFeedFromFile -- :: FilePath -> IO Feed
+ , parseFeedString -- :: String -> IO Feed
+@@ -32,7 +33,12 @@ import Text.XML.Light.Lexer ( XmlSource )
+
+ import Control.Monad
+
++#if MIN_VERSION_utf8_string(1,0,0)
++import Prelude as UTF8 (readFile)
++import Prelude
++#else
+ import System.IO.UTF8 as UTF8 ( readFile )
++#endif
+
+ -- | 'parseFeedFromFile fp' reads in the contents of the file at @fp@;
+ -- the assumed encoding is UTF-8.
diff --git a/dev-haskell/feed/metadata.xml b/dev-haskell/feed/metadata.xml
new file mode 100644
index 000000000000..c657f6d2efcf
--- /dev/null
+++ b/dev-haskell/feed/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sof/feed</remote-id>
+ </upstream>
+</pkgmetadata>