summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:04:03 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:46 +0100
commit5133f7786205ce3348741964772bb87717df4655 (patch)
treec5dd436f01bf9a946f0de3237ac70bac143d6a4b /dev-haskell/text
parentdev-haskell/transformers: Raise lower bounds on GHC (diff)
downloadgentoo-5133f7786205ce3348741964772bb87717df4655.tar.gz
gentoo-5133f7786205ce3348741964772bb87717df4655.tar.bz2
gentoo-5133f7786205ce3348741964772bb87717df4655.zip
dev-haskell/text: Raise lower bounds on GHC
Update CABAL_CORE_LIB_GHC_PV Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/text')
-rw-r--r--dev-haskell/text/metadata.xml32
-rw-r--r--dev-haskell/text/text-1.2.4.1-r1.ebuild (renamed from dev-haskell/text/text-1.2.4.1.ebuild)26
-rw-r--r--dev-haskell/text/text-1.2.5.0-r1.ebuild (renamed from dev-haskell/text/text-1.2.5.0.ebuild)28
3 files changed, 36 insertions, 50 deletions
diff --git a/dev-haskell/text/metadata.xml b/dev-haskell/text/metadata.xml
index b6cbf085cb4f..31b80dba2fcc 100644
--- a/dev-haskell/text/metadata.xml
+++ b/dev-haskell/text/metadata.xml
@@ -5,36 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
-
- An efficient packed, immutable Unicode text type (both strict and
- lazy), with a powerful loop fusion optimization framework.
-
- The 'Text' type represents Unicode character strings, in a time and
- space-efficient manner. This package provides text processing
- capabilities that are optimized for performance critical use, both
- in terms of large data quantities and high speed.
-
- The 'Text' type provides character-encoding, type-safe case
- conversion via whole-string case conversion functions. It also
- provides a range of functions for converting 'Text' values to and from
- 'ByteStrings', using several standard encodings.
-
- Efficient locale-sensitive support for text IO is also supported.
-
- These modules are intended to be imported qualified, to avoid name
- clashes with Prelude functions, e.g.
-
- &gt; import qualified Data.Text as T
-
- To use an extended and very rich family of functions for working
- with Unicode text (including normalization, regular expressions,
- non-standard encodings, text breaking, and locales), see
- the @text-icu@ package:
- &lt;http://hackage.haskell.org/package/text-icu&gt;
-
- </longdescription>
<upstream>
- <remote-id type="github">bos/text</remote-id>
+ <remote-id type="hackage">text</remote-id>
+ <remote-id type="github">haskell/text</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/text/text-1.2.4.1.ebuild b/dev-haskell/text/text-1.2.4.1-r1.ebuild
index d5c69728cb9b..853e1268efcb 100644
--- a/dev-haskell/text/text-1.2.4.1.ebuild
+++ b/dev-haskell/text/text-1.2.4.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.7.9999
-#hackport: flags: -bytestring-builder,-developer
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -bytestring-builder,-developer,-integer-simple
CABAL_FEATURES="lib profile haddock hoogle hscolour" # broken test-suite
# break circular dependencies:
@@ -14,24 +14,26 @@ inherit haskell-cabal
DESCRIPTION="An efficient packed Unicode text type"
HOMEPAGE="https://github.com/haskell/text"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/${PV}"
-# keep in sync with ghc-8.10.4
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="~amd64 ~amd64-linux"
+
# break cyclic dependencies, test suite requires porting to >=QC-2.11
RESTRICT=test
-RDEPEND=">=dev-lang/ghc-8.8:="
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+"
DEPEND="${RDEPEND}
"
-CABAL_CORE_LIB_GHC_PV="8.10.6"
-
src_configure() {
haskell-cabal_src_configure \
--flag=-bytestring-builder \
- --flag=-developer
+ --flag=-developer \
+ --flag=-integer-simple
}
+
+CABAL_CORE_LIB_GHC_PV="8.10.6 8.10.7"
diff --git a/dev-haskell/text/text-1.2.5.0.ebuild b/dev-haskell/text/text-1.2.5.0-r1.ebuild
index 68c9189b4b5e..12b2e313de16 100644
--- a/dev-haskell/text/text-1.2.5.0.ebuild
+++ b/dev-haskell/text/text-1.2.5.0-r1.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-# ebuild generated by hackport 0.7.9999
-#hackport: flags: -bytestring-builder,-developer
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -bytestring-builder,-developer,-integer-simple
CABAL_FEATURES="lib profile haddock hoogle hscolour" # circular deps in test-suite
# break circular dependencies:
@@ -14,23 +14,35 @@ inherit haskell-cabal
DESCRIPTION="An efficient packed Unicode text type"
HOMEPAGE="https://github.com/haskell/text"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/${PV}"
-#keep in sync with ghc-9.0.2
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
# break cyclic dependencies:
RESTRICT=test
-RDEPEND=">=dev-lang/ghc-8.4.3:=
+RDEPEND="
+ >=dev-lang/ghc-9.0.2:=
+"
+DEPEND="${RDEPEND}
"
-DEPEND="${RDEPEND}"
+# test? (
+# >=dev-haskell/quickcheck-2.14.1 <dev-haskell/quickcheck-2.15
+# >=dev-haskell/quickcheck-unicode-1.0.1.0
+# dev-haskell/random
+# dev-haskell/tasty
+# dev-haskell/tasty-hunit
+# dev-haskell/tasty-inspection-testing
+# dev-haskell/tasty-quickcheck
+# )
src_configure() {
haskell-cabal_src_configure \
--flag=-bytestring-builder \
- --flag=-developer
+ --flag=-developer \
+ --flag=-integer-simple
}
-CABAL_CORE_LIB_GHC_PV="9.0.2"
+CABAL_CORE_LIB_GHC_PV="9.0.2 9.2.4 9.2.5 9.2.6 9.2.7 9.2.8"