summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 09:51:36 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:33 +0100
commit3e7a16e8ddd7f8766751781a81f5c1d0780a2abd (patch)
tree52f69f2bef8119b36d547795b2bc9d5c48a9f25d /dev-haskell/yesod-auth-hashdb
parentdev-haskell/yesod: bump up to 1.6.0.2 (diff)
downloadgentoo-3e7a16e8ddd7f8766751781a81f5c1d0780a2abd.tar.gz
gentoo-3e7a16e8ddd7f8766751781a81f5c1d0780a2abd.tar.bz2
gentoo-3e7a16e8ddd7f8766751781a81f5c1d0780a2abd.zip
dev-haskell/yesod-auth-hashdb: bump up to 1.7.1.2
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/yesod-auth-hashdb')
-rw-r--r--dev-haskell/yesod-auth-hashdb/Manifest1
-rw-r--r--dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/yesod-auth-hashdb/Manifest b/dev-haskell/yesod-auth-hashdb/Manifest
index ea69c9041245..2c1593fc164d 100644
--- a/dev-haskell/yesod-auth-hashdb/Manifest
+++ b/dev-haskell/yesod-auth-hashdb/Manifest
@@ -1,2 +1,3 @@
DIST yesod-auth-hashdb-1.5.1.3.tar.gz 13367 BLAKE2B ee67116905ba799cb67e813e2096c63361ab9c4d7fdb3d64df44744e7df39b2a5754acf4f79a9b87f167a827449c6bfadc1a0bdb4df6f39f3b9110d8b7c3b0ae SHA512 2fd7de432307c2e4465b8eb9ca6af6e1ede0fb8a3e09f9a6d04cff63d03c2db57eba2282f3441b45c82774bb063fa1d5546b832ca521074304e03343010a1952
DIST yesod-auth-hashdb-1.5.1.tar.gz 12987 BLAKE2B c0a715d26950de505e76900b309572b78ca28d8bcbd6c3c5935c91a6e614e46bb05089c442d154703ba230ab2e591bb16b1bb2fdaabac68bb51b1496030db956 SHA512 9fbbd5b3b8bdd56e0e35a7609408fff034ba320e8271655ae29d75b1a75dd7c4ef9cebc4f94ed991137940d8161ec8560af6bf3c397d86de78e447adaf741ccf
+DIST yesod-auth-hashdb-1.7.1.2.tar.gz 15751 BLAKE2B cff24e8957a68539c168466f77433fee064aa76b8426e9c1023ff704c990d0b774341c113bae066b30bbcb01e1c1199f8c6dcd9431e574838c67863a63f791a5 SHA512 417c5113530b6960f30e5209f0188c5367361acfbea2eb60a6d30a9facb5a3be6d8547dfa504da4f7a7585d8c848adbaafa0a28ffea6930f9954071e6e2647e2
diff --git a/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild b/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild
new file mode 100644
index 000000000000..67438bbc6ba1
--- /dev/null
+++ b/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication plugin for Yesod"
+HOMEPAGE="https://github.com/paul-rouse/yesod-auth-hashdb"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.11:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/yesod-auth-1.4.18:=[profile?] <dev-haskell/yesod-auth-1.7:=[profile?]
+ >=dev-haskell/yesod-core-1.4.19:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
+ >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.7:=[profile?]
+ >=dev-haskell/yesod-persistent-1.2:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( dev-haskell/basic-prelude
+ >=dev-haskell/hspec-2.0.0
+ dev-haskell/http-conduit
+ dev-haskell/http-types
+ dev-haskell/monad-logger
+ dev-haskell/network-uri
+ dev-haskell/persistent-sqlite
+ dev-haskell/resourcet
+ dev-haskell/unordered-containers
+ dev-haskell/wai-extra
+ dev-haskell/yesod
+ >=dev-haskell/yesod-test-1.5.0.1
+ || ( ( >=dev-haskell/yesod-auth-1.4.18 <dev-haskell/yesod-auth-1.5 )
+ ( >=dev-haskell/yesod-auth-1.6.1 <dev-haskell/yesod-auth-1.7 ) ) )
+"