summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-14 19:30:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-14 19:39:44 +0000
commit6617c5a955fa8c4c7397215a9fa235e214acd6d5 (patch)
tree3214afdc2d470f35449253254bdd13488e9d060a /dev-haskell
parentdev-haskell/mutable-containers: bump up to 0.3.4 (diff)
downloadgentoo-6617c5a955fa8c4c7397215a9fa235e214acd6d5.tar.gz
gentoo-6617c5a955fa8c4c7397215a9fa235e214acd6d5.tar.bz2
gentoo-6617c5a955fa8c4c7397215a9fa235e214acd6d5.zip
dev-haskell/mtl-compat: bump up to 0.2.2
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/mtl-compat/Manifest1
-rw-r--r--dev-haskell/mtl-compat/mtl-compat-0.2.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/mtl-compat/Manifest b/dev-haskell/mtl-compat/Manifest
index 296a4e877f7d..db1759b3fca5 100644
--- a/dev-haskell/mtl-compat/Manifest
+++ b/dev-haskell/mtl-compat/Manifest
@@ -1 +1,2 @@
DIST mtl-compat-0.2.1.3.tar.gz 4584 BLAKE2B 47cfbaf9f60f586318a0aa838e64d0ae13fe69386b738e3c45eb393acb77176c85a9e99f7c81384704d177bf7c895f866813880ba0f2285116a566f24114645c SHA512 c9afa97eb5dc1bddcbf0e088352141d56b603562f80fcbde6811610a4e71e1496dd5f07e4338644930bf06b403bc08d35799f7063ae845ecdb71e619b2342a18
+DIST mtl-compat-0.2.2.tar.gz 5128 BLAKE2B e1066f61c8087ffd6c8afc9545dd73402b01e9995fcbe226094777f93623f93209c7afdcd01fe2a5fdae4fc4aa2d39eeb821772ce9d542c80f7d0714d25dc79f SHA512 78a93e9e59d01bf0ffeb32f1322decd65d87cba8912d00f77347f0fc2f7190a755297953ac363ca3342c83822d36101b43ef044dc1f3b2ffef7c7710afda9d0d
diff --git a/dev-haskell/mtl-compat/mtl-compat-0.2.2.ebuild b/dev-haskell/mtl-compat/mtl-compat-0.2.2.ebuild
new file mode 100644
index 000000000000..544821d4286f
--- /dev/null
+++ b/dev-haskell/mtl-compat/mtl-compat-0.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile" # haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Backported Control.Monad.Except module from mtl"
+HOMEPAGE="https://github.com/haskell-compat/mtl-compat"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ dev-haskell/transformers-compat:=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ local mtl_arg=()
+
+ has_version '>=dev-haskell/mtl-2.0.1' && \
+ has_version '<dev-haskell/mtl-2.2' && \
+ mtl_arg+=(--flag=two-point-one)
+ has_version '>=dev-haskell/mtl-2.2.0.1' && \
+ has_version '<dev-haskell/mtl-2.2.1' && \
+ mtl_arg+=(--flag=two-point-two)
+ haskell-cabal_src_configure \
+ ${mtl_arg}
+}