summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2015-12-04 18:53:57 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2015-12-04 18:56:26 +0100
commitcdc69ecf43618ce8cb65884b92e6930d3c7485dc (patch)
tree3c1e25997b182d910dbca08fd330bee3d205d728 /dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.5.1.ebuild
parentdev-java/eclipse-ecj: version bump - new slot 4.5 (diff)
downloadgentoo-cdc69ecf43618ce8cb65884b92e6930d3c7485dc.tar.gz
gentoo-cdc69ecf43618ce8cb65884b92e6930d3c7485dc.tar.bz2
gentoo-cdc69ecf43618ce8cb65884b92e6930d3c7485dc.zip
dev-java/ant-eclipse-ecj: version bump - new slot 4.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.5.1.ebuild')
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.5.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.5.1.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.5.1.ebuild
new file mode 100644
index 000000000000..5954842302a9
--- /dev/null
+++ b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple prefix
+
+DMF="R-${PV}-201509040015"
+
+DESCRIPTION="Ant Compiler Adapter for Eclipse Java Compiler"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops4/${DMF}/ecjsrc-${PV}.jar"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="4.5"
+IUSE=""
+
+CDEPEND="~dev-java/eclipse-ecj-${PV}:${SLOT}
+ >=dev-java/ant-core-1.7"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+DEPEND="${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.7"
+
+JAVA_GENTOO_CLASSPATH="ant-core,eclipse-ecj-${SLOT}"
+
+java_prepare() {
+ # Remove everything but the Ant component.
+ find org -type f ! -path "org/eclipse/jdt/internal/antadapter/*" ! -name "JDTCompilerAdapter.java" -delete || die
+
+ rm build.xml || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ find org -type f ! -name "*.java" | xargs jar uvf "${PN}.jar" || die "jar update failed"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ insinto /usr/share/java-config-2/compiler
+ doins "${FILESDIR}/ecj-${SLOT}"
+ eprefixify "${D}"/usr/share/java-config-2/compiler/ecj-${SLOT}
+}