summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-04-01 11:05:41 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-04-01 11:06:39 +0200
commit9e5336816419cec735191f530e9616f4b1e2f25d (patch)
tree02647fa552a41a3600353f5f7801c7c8d1b04011 /dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild
parentdev-java/jgraph: clean up old. (diff)
downloadgentoo-9e5336816419cec735191f530e9616f4b1e2f25d.tar.gz
gentoo-9e5336816419cec735191f530e9616f4b1e2f25d.tar.bz2
gentoo-9e5336816419cec735191f530e9616f4b1e2f25d.zip
dev-java/jgoodies-animation: EAPI 6 bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --force
Diffstat (limited to 'dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild')
-rw-r--r--dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..2ad90150c273
--- /dev/null
+++ b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_V=${PV//./_}
+
+DESCRIPTION="JGoodies Animation Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="mirror://gentoo/animation-${MY_V}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ app-arch/unzip
+ >=virtual/jdk-1.6
+ test? ( dev-java/ant-junit:0 )"
+
+RDEPEND="
+ >=virtual/jre-1.6
+ examples? (
+ >=dev-java/jgoodies-binding-1.1:1.0
+ >=dev-java/jgoodies-forms-1.0:0
+ )"
+
+S="${WORKDIR}/animation-${PV}"
+
+EANT_FILTER_COMPILER="jikes"
+EANT_DOC_TARGET=""
+
+DOCS=( RELEASE-NOTES.txt README.html )
+
+src_prepare() {
+ default
+
+ java-pkg_clean
+}
+
+src_test() {
+ eant test -Djunit.jar.present=true \
+ -Djunit.jar=$(java-pkg_getjar junit junit.jar)
+}
+
+src_install() {
+ java-pkg_dojar build/animation.jar
+ einstalldocs
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/core/*
+ use examples && java-pkg_doexamples src/tutorial
+}