summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-03-10 19:09:24 +0100
committerPetr Vaněk <arkamar@gentoo.org>2024-04-14 21:14:05 +0200
commit8006dc80dedd08b1c460cfd6623d3384811b05e5 (patch)
treedbc80913f90b24fc54022ade0697edfe6d124952 /dev-lang/elixir/elixir-1.16.2.ebuild
parentdev-util/pkgcheck: Stabilize 0.10.29 ppc, #930025 (diff)
downloadgentoo-8006dc80dedd08b1c460cfd6623d3384811b05e5.tar.gz
gentoo-8006dc80dedd08b1c460cfd6623d3384811b05e5.tar.bz2
gentoo-8006dc80dedd08b1c460cfd6623d3384811b05e5.zip
dev-lang/elixir: add 1.16.2
Includes the following upstream patch to skip tests relying on erlang[doc]: https://github.com/elixir-lang/elixir/commit/c50863615c0e8ac957e22ae01a6f9af23978c3f9 Closes: https://bugs.gentoo.org/925670 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-lang/elixir/elixir-1.16.2.ebuild')
-rw-r--r--dev-lang/elixir/elixir-1.16.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/elixir/elixir-1.16.2.ebuild b/dev-lang/elixir/elixir-1.16.2.ebuild
new file mode 100644
index 000000000000..429d175339cf
--- /dev/null
+++ b/dev-lang/elixir/elixir-1.16.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Elixir programming language"
+HOMEPAGE="https://elixir-lang.org"
+SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 ErlPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~riscv ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+# https://hexdocs.pm/elixir/compatibility-and-deprecations.html#between-elixir-and-erlang-otp
+DEPEND="
+ >=dev-lang/erlang-24:0=[ssl]
+ <dev-lang/erlang-27
+"
+# 'mix' tool collides with sci-biology/phylip, bug #537514
+RDEPEND="${DEPEND}
+ !!sci-biology/phylip
+"
+DEPEND+="
+ test? ( dev-vcs/git )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
+ "${FILESDIR}"/${PN}-1.10.3-no-Q.patch
+ "${FILESDIR}"/${PN}-1.10.3-epmd-daemon.patch
+ "${FILESDIR}"/${PN}-1.16.1-skip-tests-requiring-erlang-docs.patch
+)
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
+}