summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-04-21 10:24:51 +0000
committerMatthew Smith <matthew@gentoo.org>2024-04-21 10:24:51 +0000
commit1d9f81cd12efcf7593d096c23f25834e2cb72513 (patch)
tree61f715b002d13a367719d3409f7744d9dd07cfdd /dev-lang
parentx11-misc/fbpanel: enable py3.12 (diff)
downloadgentoo-1d9f81cd12efcf7593d096c23f25834e2cb72513.tar.gz
gentoo-1d9f81cd12efcf7593d096c23f25834e2cb72513.tar.bz2
gentoo-1d9f81cd12efcf7593d096c23f25834e2cb72513.zip
dev-lang/nasm: add 2.16.03
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nasm/Manifest1
-rw-r--r--dev-lang/nasm/nasm-2.16.03.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-lang/nasm/Manifest b/dev-lang/nasm/Manifest
index 48b66ce7fc14..3c759667d311 100644
--- a/dev-lang/nasm/Manifest
+++ b/dev-lang/nasm/Manifest
@@ -1,2 +1,3 @@
DIST nasm-2.16.01.tar.xz 1017732 BLAKE2B 0f7e96648e3db6fa4a8e10a89885f61cab7d79af25adbcc9d4706b3af61206c3cae024b7f873d636f5c1b2cb34ce5e7fbecc16af9b59086e9a1f49fb37c59670 SHA512 51fccb5639ce019d9c423c0f279750ffbd74c64cd41dd3b185d1aa1a1aaed79c5d3cd8d4bebbc13ee249a375ed27457ea2abde1a4dbb24d354598fffd1254833
DIST nasm-2.16.02.tar.xz 1044824 BLAKE2B daa3585e9aef3c388e3b577a52453b31aaa7f13942e621c21bbe6ec744ff30bf2692e853dda193b30006989cb10e40dcc1cf0107176e31fd5ee096baad28c7a1 SHA512 9ccafb4cd9064fb21f6551309d35ba7461de8da138b1239d76c2ea0c070a1a767f1019d5d705088375d625cfb73eebbfd9dfa3588107793b95354d89dcfd22c3
+DIST nasm-2.16.03.tar.xz 1032388 BLAKE2B 742cbf330341fde9f778d8ca13e8c06199f48796d47028ac973d39e3d9e434450cdfebe89f6ab248d372bdaeb0c88a25eb7153a39b66fc05e770523d4c9e11e9 SHA512 0c706e41a9c33e1ac3bad5056e8bf8cbcd51785b551a6e34ce7d0d723df8eaab8603a033e89b3dcda1004b558f9e9ef3196691500f10d8201bf47a323a516f84
diff --git a/dev-lang/nasm/nasm-2.16.03.ebuild b/dev-lang/nasm/nasm-2.16.03.ebuild
new file mode 100644
index 000000000000..4c03189e21b1
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.16.03.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="https://www.nasm.us/"
+SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+S="${WORKDIR}"/${P/_}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc lto"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Windows.
+ _BitScanReverse
+ _BitScanReverse64
+
+ # Linux headers that are not included.
+ __cpu_to_le16
+ __cpu_to_le32
+ __cpu_to_le64
+ _byteswap_uint64
+ _byteswap_ulong
+ _byteswap_ushort
+ cpu_to_le16
+ cpu_to_le32
+ cpu_to_le64
+
+ # __typeof as gnu extensions are not enabled
+ typeof
+
+ # musl doesn't define __bswap_N in endian.h (it's named _bswapN
+ # instead). could be fixed to call this instead, or to include
+ # musl's byteswap.h instead, but it is much easier to fall back on
+ # __builtin_bswapN. Bug #928848
+ __bswap_16
+ __bswap_32
+ __bswap_64
+)
+
+# [fonts note] doc/psfonts.ph defines ordered list of font preference.
+# Currently 'media-fonts/source-pro' is most preferred and is able to
+# satisfy all 6 font flavours: tilt, chapter, head, etc.
+BDEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/source-code-pro
+ media-fonts/source-sans:3
+ virtual/perl-File-Spec
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.15-bsd-cp-doc.patch
+)
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/870214
+ # During the split of media-fonts/source-pro, the source-sans files
+ # were renamed. Currently depend on media-fonts/source-sans:3 which works
+ # with this sed.
+ sed -i 's/SourceSansPro/SourceSans3/g' doc/psfonts.ph || die
+
+ AT_M4DIR="${S}/autoconf/m4" eautoreconf
+}
+
+src_configure() {
+ local myconfargs=(
+ $(use_enable lto)
+ )
+ econf "${myconfargs[@]}"
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install $(usex doc install_doc '')
+}