summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-21 01:44:23 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-21 02:59:31 -0800
commitad6bba71bd9926a26b4c71fbac084c4086f71538 (patch)
tree604c14287874cfe124e5af79983f357c10808ec2 /dev-lang
parentbase/package.use.stable.mask: mask rust[nightly] (diff)
downloadgentoo-ad6bba71bd9926a26b4c71fbac084c4086f71538.tar.gz
gentoo-ad6bba71bd9926a26b4c71fbac084c4086f71538.tar.bz2
gentoo-ad6bba71bd9926a26b4c71fbac084c4086f71538.zip
dev-lang/rust: add nightly useflag to 1.40.0
this will allow installing stable release with nightly features enabled Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/metadata.xml1
-rw-r--r--dev-lang/rust/rust-1.40.0.ebuild4
2 files changed, 3 insertions, 2 deletions
diff --git a/dev-lang/rust/metadata.xml b/dev-lang/rust/metadata.xml
index 7a1b62bcd0fc..17963dc4e81d 100644
--- a/dev-lang/rust/metadata.xml
+++ b/dev-lang/rust/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="clippy">Install clippy component</flag>
<flag name="system-llvm">Use the system LLVM install</flag>
+ <flag name="nightly">Enable nightly (UNSTABLE) features</flag>
<flag name="rls">Install rls component</flag>
<flag name="rustfmt">Install rustfmt component</flag>
<flag name="wasm">Build support for the wasm32-unknown-unknown
diff --git a/dev-lang/rust/rust-1.40.0.ebuild b/dev-lang/rust/rust-1.40.0.ebuild
index 5b5894917d64..9985a7e76ed2 100644
--- a/dev-lang/rust/rust-1.40.0.ebuild
+++ b/dev-lang/rust/rust-1.40.0.ebuild
@@ -36,7 +36,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug doc libressl rls rustfmt system-llvm wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="clippy cpu_flags_x86_sse2 debug doc libressl nightly rls rustfmt system-llvm wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
@@ -187,7 +187,7 @@ src_configure() {
debug = $(toml_usex debug)
debug-assertions = $(toml_usex debug)
default-linker = "$(tc-getCC)"
- channel = "stable"
+ channel = "$(usex nightly nightly stable)"
rpath = false
lld = $(usex system-llvm false $(toml_usex wasm))
EOF