summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-27 15:44:52 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-27 19:51:48 +0100
commite068d55c4a56f15e54ef4edde0a480bfbb440c79 (patch)
tree67df689558e34a2bb4759630e3f2e48b9a284520 /dev-lang
parentdev-util/shards: bump to 0.19.0 (diff)
downloadgentoo-e068d55c4a56f15e54ef4edde0a480bfbb440c79.tar.gz
gentoo-e068d55c4a56f15e54ef4edde0a480bfbb440c79.tar.bz2
gentoo-e068d55c4a56f15e54ef4edde0a480bfbb440c79.zip
dev-lang/dafny-bin: bump to 4.9.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/dafny-bin/Manifest1
-rw-r--r--dev-lang/dafny-bin/dafny-bin-4.9.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index da454225794f..df4ea676f7c2 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1 +1,2 @@
DIST dafny-4.9.0-x64-ubuntu-20.04.zip 60772912 BLAKE2B 5904811590362705183e05e38c5f67a98b1601c28b4776faf3f33ac87d527e2c91493a0a693fd635799b8f416344acab2ed8c2897f3d1f07827e34565e8d720e SHA512 f44b94abf4fb9b42ee7b7fab584d1b6d65a90bdc515b2b4fc398762bcc33a759bbe2e22ff0c9fc556ca1794707cd7ca440e414c51be10ecd87a5b470df661bbf
+DIST dafny-4.9.1-x64-ubuntu-20.04.zip 60815385 BLAKE2B 76e4b7cf6bfea6f97bb04b77c034cf62732cc9fcadf1893f4783cf9e44cffc81f4067bbc001474b3b0a92f699b329f87ec77a2e34747a945d7786a33e6fff5b6 SHA512 37fdc7ab2f3feab6cce86103d57248e671daca91aead6588cb9f8de34e4b229178cb2da8bcc5bc26a45b85b76bb445c4c87c440d6e6a84409e2a3fdf7d34765f
diff --git a/dev-lang/dafny-bin/dafny-bin-4.9.1.ebuild b/dev-lang/dafny-bin/dafny-bin-4.9.1.ebuild
new file mode 100644
index 000000000000..2907f72117f4
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-4.9.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/
+ https://github.com/dafny-lang/dafny/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-20.04.zip"
+S="${WORKDIR}/dafny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="elibc_glibc"
+RESTRICT="strip"
+
+RDEPEND="
+ !dev-lang/dafny
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust:0/2.12
+ sci-mathematics/z3
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used
+ # by, for example, compiling/verifying a simple dafny program.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest="/opt/dafny"
+
+ insinto "${dest}"
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym "../../${dest}/${bin}" "/usr/bin/${bin}"
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym -r "/${dest}/DafnyServer" /usr/bin/dafny-server
+}