summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-15 12:03:54 +0000
committerSam James <sam@gentoo.org>2024-12-15 12:05:05 +0000
commitb992d922dfc15e6d8757c23fb8c0093f70bc3f54 (patch)
treeb2c68b46b0f39ae43c9e8d9f538d6bad00fd5182 /dev-libs/glib
parentdev-libs/efl: fix build error for gcc 15 and clang 19 (diff)
downloadgentoo-b992d922dfc15e6d8757c23fb8c0093f70bc3f54.tar.gz
gentoo-b992d922dfc15e6d8757c23fb8c0093f70bc3f54.tar.bz2
gentoo-b992d922dfc15e6d8757c23fb8c0093f70bc3f54.zip
dev-libs/glib: disable new assertions by default
As reported in the bug and per upstream commit b02e29558fca8053fcb811fbf5691c09a876bb5a, -Dglib_debug is default-enabled in >=2.80 but they recommend distros default it to off, so let's do that. Closes: https://bugs.gentoo.org/946485 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/glib-2.82.4-r1.ebuild (renamed from dev-libs/glib/glib-2.82.4.ebuild)2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-2.82.4.ebuild b/dev-libs/glib/glib-2.82.4-r1.ebuild
index 533b2a2ae85d..ac8c41e59cfb 100644
--- a/dev-libs/glib/glib-2.82.4.ebuild
+++ b/dev-libs/glib/glib-2.82.4-r1.ebuild
@@ -287,11 +287,13 @@ multilib_src_configure() {
export PYTHONPATH="${INTROSPECTION_LIB_DIR}/gobject-introspection:${PYTHONPATH}"
fi
+ # TODO: Can this be cleaned up now we have -Dglib_debug? (bug #946485)
use debug && EMESON_BUILD_TYPE=debug
local emesonargs=(
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
+ $(meson_feature debug glib_debug)
$(meson_feature selinux)
$(meson_use xattr)
-Dlibmount=enabled # only used if host_system == 'linux'