summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-27 17:18:26 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-27 17:35:06 -0400
commite5c735ce354f82c3efde8884d0805df91c8cd21c (patch)
tree60283fddaee9261c39d0f5984b588051f39ce602 /dev-libs/libgweather
parentx11-libs/pango: Version bump to 1.48.4 (diff)
downloadgentoo-e5c735ce354f82c3efde8884d0805df91c8cd21c.tar.gz
gentoo-e5c735ce354f82c3efde8884d0805df91c8cd21c.tar.bz2
gentoo-e5c735ce354f82c3efde8884d0805df91c8cd21c.zip
dev-libs/libgweather: Version bump to 3.36.2
Closes: https://bugs.gentoo.org/777567 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/Manifest1
-rw-r--r--dev-libs/libgweather/files/3.36.2-autoskip-network-test.patch29
-rw-r--r--dev-libs/libgweather/libgweather-3.36.2.ebuild70
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index 11c7d1bec28c..f833821c1a24 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -1 +1,2 @@
DIST libgweather-3.36.1.tar.xz 2702144 BLAKE2B bd867461b64ef81607695ae1a3796d2b096129a9a60721c5fcb20d8c35859c0b76a985e9393c23b311f7c0fdec3e691618eab83a826b483c427287906d575251 SHA512 6c7090b0b6dfac61e73a398d34329cd706080a007694ceb3d47700b4f444982f8ca989dd6dfaefe85b79ffd5af9c423be4bf1bd8491ac0ba6bd15c150d97b26d
+DIST libgweather-3.36.2.tar.xz 2707976 BLAKE2B 0051e1fe9dccef44ff6fe46bdf8e6b23c9a772ed000daf3a0349e064819d0f17f3f7d902f9c860f0d186a67fc6c5a27b31a8b20b4fec7e738221a58830216ca5 SHA512 58012931382d87b10ace79f6e2337a9244a0877a8bc241bad5da6368f6d8eaa815f88bee25cfd49b12baa4b2399a407b905f1cf0afb98f649fda6b0dc9f61f01
diff --git a/dev-libs/libgweather/files/3.36.2-autoskip-network-test.patch b/dev-libs/libgweather/files/3.36.2-autoskip-network-test.patch
new file mode 100644
index 000000000000..bc35bb3c4fd5
--- /dev/null
+++ b/dev-libs/libgweather/files/3.36.2-autoskip-network-test.patch
@@ -0,0 +1,29 @@
+From 4bc5b6792706788f0930bda7049adf349713a2cc Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 30 Aug 2020 10:35:13 +0300
+Subject: [PATCH] tests: Skip metar tests when METAR_SOURCES couldn't be
+ resolved
+
+---
+ libgweather/test_libgweather.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/libgweather/test_libgweather.c b/libgweather/test_libgweather.c
+index b481278d..5704bd8b 100644
+--- a/libgweather/test_libgweather.c
++++ b/libgweather/test_libgweather.c
+@@ -424,6 +424,11 @@ test_metar_weather_stations (void)
+ g_test_message ("SSL/TLS failure, please check your glib-networking installation");
+ g_test_failed ();
+ return;
++ } else if (msg->status_code == SOUP_STATUS_CANT_RESOLVE) {
++ g_test_skip ("Could not resolve " METAR_SOURCES " - network sandboxed?");
++ g_object_unref (session);
++ g_object_unref (msg);
++ return;
+ }
+ g_assert_cmpint (msg->status_code, >=, 200);
+ g_assert_cmpint (msg->status_code, <, 300);
+--
+2.26.2
+
diff --git a/dev-libs/libgweather/libgweather-3.36.2.ebuild b/dev-libs/libgweather/libgweather-3.36.2.ebuild
new file mode 100644
index 000000000000..6c35cbd8b673
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.36.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Location and timezone database and weather-lookup library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-16-2" # subslot = 3-(libgweather-3 soname suffix) w/ temporary -2 suffix for silent ABI break after 3.28 without soname bump as per distro-list
+
+IUSE="glade gtk-doc +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=x11-libs/gtk+-3.13.5:3[introspection?]
+ >=net-libs/libsoup-2.44:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ sci-geosciences/geocode-glib
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.11
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+PATCHES=(
+ "${FILESDIR}"/3.32.1-meson-tweaks.patch # Provide introspection optionality and don't build tests that aren't ran automatically
+ "${FILESDIR}"/3.36.1-tests-locale.patch # Don't fail tests when a locale is not present, https://gitlab.gnome.org/GNOME/libgweather/-/merge_requests/58
+ "${FILESDIR}"/3.36.2-autoskip-network-test.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use glade glade_catalog)
+ $(meson_use vala enable_vala)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}