summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-23 17:24:40 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-23 17:24:40 -0400
commit5a3269ea24eb26fbec3b6bb29ab89f9ecb1b3642 (patch)
tree2a0dd5f574c660e29fd01c4fc8291ea7e286516d /dev-libs/libreport/libreport-2.9.5.ebuild
parentapp-text/odt2txt: amd64 stable wrt bug #656164 (diff)
downloadgentoo-5a3269ea24eb26fbec3b6bb29ab89f9ecb1b3642.tar.gz
gentoo-5a3269ea24eb26fbec3b6bb29ab89f9ecb1b3642.tar.bz2
gentoo-5a3269ea24eb26fbec3b6bb29ab89f9ecb1b3642.zip
dev-libs/libreport: bump
Closes: https://bugs.gentoo.org/467726 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libreport/libreport-2.9.5.ebuild')
-rw-r--r--dev-libs/libreport/libreport-2.9.5.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/libreport/libreport-2.9.5.ebuild b/dev-libs/libreport/libreport-2.9.5.ebuild
new file mode 100644
index 000000000000..fab10399795b
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.9.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools ltprune python-r1 user
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+gtk python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ >=dev-libs/glib-2.43:2
+ dev-libs/satyr
+ dev-libs/json-c:=
+ dev-libs/libtar
+ dev-libs/libxml2:2
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup abrt
+ enewuser abrt -1 -1 -1 abrt
+}
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ # Fixes "syntax error in VERSION script" and we aren't supporting Python2 anyway
+ --without-python2
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ econf "${myargs[@]}"
+}
+
+src_install() {
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ prune_libtool_files --modules
+}