summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/librra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/librra')
-rw-r--r--dev-libs/librra/Manifest1
-rw-r--r--dev-libs/librra/librra-0.16.ebuild52
-rw-r--r--dev-libs/librra/metadata.xml11
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/librra/Manifest b/dev-libs/librra/Manifest
new file mode 100644
index 000000000000..4fb8d416663b
--- /dev/null
+++ b/dev-libs/librra/Manifest
@@ -0,0 +1 @@
+DIST librra-0.16.tar.gz 451305 SHA256 3abc51a2e64a09c4fd85ded9e3ea01f744e1f4ff6c8b0bf49cbfb8dec3a3a32d SHA512 be2e1dd7614630bc001111ebbb75ed791c094b38ee3a04ad667d5d5d414ad6c7b16bb264617125d74d0d23e90118e208dce5442ed238a18a75df092894380f69 WHIRLPOOL 1d3372cff0d732104ec9291ab67b1fe722f32fe158597bddcdcb58b0a260569733b97faaded8dbe940f9b8d8ef25df129656a9d2c894572b7ff938fbf7061b5c
diff --git a/dev-libs/librra/librra-0.16.ebuild b/dev-libs/librra/librra-0.16.ebuild
new file mode 100644
index 000000000000..53c08c2cbf3c
--- /dev/null
+++ b/dev-libs/librra/librra-0.16.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.7"
+
+inherit python
+
+DESCRIPTION="Implements the RRA protocol, for syncing pre WM-2005 PIM data, and files for all versions"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python recurrence static-libs"
+
+RDEPEND=">=app-pda/synce-core-0.16[python?]
+ >=dev-libs/libmimedir-0.5.1
+ python? ( >=dev-python/pyrex-0.9.6 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable recurrence) \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README TODO
+ newdoc lib/README README.lib
+ newdoc src/README README.src
+
+ # prune_libtool_files() from eutils.eclass fails wrt #421197
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # Always remove static archive from site-packages
+ use static-libs && find "${ED}" -name pyrra.a -exec rm -f {} +
+}
diff --git a/dev-libs/librra/metadata.xml b/dev-libs/librra/metadata.xml
new file mode 100644
index 000000000000..4c4dfee99541
--- /dev/null
+++ b/dev-libs/librra/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <use>
+ <flag name="recurrence">Enable recurrence support (EXPERIMENTAL)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">synce</remote-id>
+ </upstream>
+</pkgmetadata>