summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-28 19:13:17 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-10-30 00:14:54 +0100
commita05299dd81c8b959f5590e975e8f1c170e84b6b8 (patch)
treea3f63ae91b78df245183617e46eea5c91d1f0441 /dev-libs/nmeap/nmeap-0.3-r1.ebuild
parentapp-misc/prog-express: drop old version. (diff)
downloadgentoo-a05299dd81c8b959f5590e975e8f1c170e84b6b8.tar.gz
gentoo-a05299dd81c8b959f5590e975e8f1c170e84b6b8.tar.bz2
gentoo-a05299dd81c8b959f5590e975e8f1c170e84b6b8.zip
dev-libs/nmeap: bump to EAPI=7.
Also updated metadata.xml and fixed a compiler warning. Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10279 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-libs/nmeap/nmeap-0.3-r1.ebuild')
-rw-r--r--dev-libs/nmeap/nmeap-0.3-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/nmeap/nmeap-0.3-r1.ebuild b/dev-libs/nmeap/nmeap-0.3-r1.ebuild
new file mode 100644
index 000000000000..61aa260e3f1a
--- /dev/null
+++ b/dev-libs/nmeap/nmeap-0.3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extensible NMEA-0183 (GPS) data parser in standard C"
+HOMEPAGE="http://nmeap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}/${P}-fix-unitialized-variable.patch" )
+
+src_prepare() {
+ default
+
+ # Repsect users CFLAGS for the static lib archive
+ sed -i -e 's/CFLAGS =/CFLAGS +=/' -e 's/-g -O0 -Werror//' src/Makefile || die
+
+ # Don't build test programs, as they are not needed
+ sed -i -e '/TST/d' Makefile || die
+
+ # Silent output of Doxygen and update it, since it is quite old
+ if use doc; then
+ sed -i -e 's/QUIET.*/QUIET = YES/' Doxyfile || die
+ doxygen -u Doxyfile 2>/dev/null || die
+ fi
+}
+
+src_compile() {
+ local myemakeopts=(
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ )
+
+ emake "${myemakeopts[@]}"
+
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ dolib.a lib/libnmeap.a
+
+ doheader inc/nmeap.h inc/nmeap_def.h
+
+ if use doc; then
+ local HTML_DOCS=( "doc/tutorial.html" "doc/html" )
+ fi
+
+ einstalldocs
+}