summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-10-05 22:05:20 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-10-05 22:25:47 +0300
commit7a379670a34fad8ab0bb064eeebd9d012ff6b4bb (patch)
treee90600f88bb5039384c6e0c80270476715a286e6 /dev-libs/npth
parentxfce-base/xfce4-session: Fix relying on implicit dbus header paths (diff)
downloadgentoo-7a379670a34fad8ab0bb064eeebd9d012ff6b4bb.tar.gz
gentoo-7a379670a34fad8ab0bb064eeebd9d012ff6b4bb.tar.bz2
gentoo-7a379670a34fad8ab0bb064eeebd9d012ff6b4bb.zip
dev-libs/npth: eapi bump
Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Diffstat (limited to 'dev-libs/npth')
-rw-r--r--dev-libs/npth/npth-1.6-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/npth/npth-1.6-r1.ebuild b/dev-libs/npth/npth-1.6-r1.ebuild
new file mode 100644
index 000000000000..14e2fc70b370
--- /dev/null
+++ b/dev-libs/npth/npth-1.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit libtool
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ elibtoolize # for Solaris shared library
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}