summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 21:32:46 +0000
committerSam James <sam@gentoo.org>2021-03-16 21:32:46 +0000
commit5e60c807e905109484bcca17eaba8c46dd58c40d (patch)
tree8c2133ad4533202aa77eb698d44b3370ab2bcb21 /dev-libs/ntl
parentapp-misc/wipe: update EAPI 6 -> 7, musl patch (diff)
downloadgentoo-5e60c807e905109484bcca17eaba8c46dd58c40d.tar.gz
gentoo-5e60c807e905109484bcca17eaba8c46dd58c40d.tar.bz2
gentoo-5e60c807e905109484bcca17eaba8c46dd58c40d.zip
dev-libs/ntl: handle removing .la differently
Closes: https://bugs.gentoo.org/775884 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/ntl')
-rw-r--r--dev-libs/ntl/ntl-11.4.4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/ntl/ntl-11.4.4.ebuild b/dev-libs/ntl/ntl-11.4.4.ebuild
index 0a9584119e17..18f21afb1eb0 100644
--- a/dev-libs/ntl/ntl-11.4.4.ebuild
+++ b/dev-libs/ntl/ntl-11.4.4.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="High-performance and portable C++ number theory library"
@@ -54,8 +55,11 @@ src_configure() {
src_install() {
default
+
if ! use static-libs; then
- rm "${ED}/usr/$(get_libdir)"/libntl.{la,a} || die
+ # bug #775884
+ find "${ED}" -name '*.la' -delete || die
+ rm "${ED}/usr/$(get_libdir)"/libntl.a || die
fi
rm -r "${ED}"/usr/share/doc/NTL || die