summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2022-06-08 01:00:00 +0000
committerYixun Lan <dlan@gentoo.org>2022-07-07 21:56:21 +0800
commit0b203688590d6f9816cc71b847f3997b796455bf (patch)
treeea7b4b16fa048f50f38f4afc50ace5a8aca1ea4c /dev-libs/oniguruma/oniguruma-6.9.8.ebuild
parentdev-libs/oniguruma: Use EAPI="8" (diff)
downloadgentoo-0b203688590d6f9816cc71b847f3997b796455bf.tar.gz
gentoo-0b203688590d6f9816cc71b847f3997b796455bf.tar.bz2
gentoo-0b203688590d6f9816cc71b847f3997b796455bf.zip
dev-libs/oniguruma: Version bump (6.9.8)
Bug: https://bugs.gentoo.org/841893 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs/oniguruma/oniguruma-6.9.8.ebuild')
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.8.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/oniguruma-6.9.8.ebuild b/dev-libs/oniguruma/oniguruma-6.9.8.ebuild
new file mode 100644
index 000000000000..86e9755fe4c8
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-6.9.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2003-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/kkos/oniguruma"
+fi
+
+DESCRIPTION="Regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="crnl-as-line-terminator static-libs"
+
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/onig-${PV}"
+fi
+
+DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-posix-api \
+ $(use_enable crnl-as-line-terminator) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}