summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-09-18 16:30:45 -0400
committerCraig Andrews <candrews@gentoo.org>2020-09-18 16:31:17 -0400
commitaa2e3525b6925a87db74c73cc30a6f97d1dd3511 (patch)
tree3326d3b4669db497e0762effbe5bbbcee018322c /dev-libs/rocm-comgr
parentdev-libs/rocm-device-libs: 3.8.0 version bump (diff)
downloadgentoo-aa2e3525b6925a87db74c73cc30a6f97d1dd3511.tar.gz
gentoo-aa2e3525b6925a87db74c73cc30a6f97d1dd3511.tar.bz2
gentoo-aa2e3525b6925a87db74c73cc30a6f97d1dd3511.zip
dev-libs/rocm-comgr: 3.8.0 version bump
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-comgr')
-rw-r--r--dev-libs/rocm-comgr/Manifest1
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-3.8.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/rocm-comgr/Manifest b/dev-libs/rocm-comgr/Manifest
index f5bcffb66d96..d2a10637ab89 100644
--- a/dev-libs/rocm-comgr/Manifest
+++ b/dev-libs/rocm-comgr/Manifest
@@ -1 +1,2 @@
DIST rocm-comgr-3.7.0.tar.gz 94875 BLAKE2B 0d6b01360cbdb4a40aab9dadcc56389a3edc11380fe1c39a29a9f3c0356708ae95ce8918bf9d4d4fa46c1a077a2daf99c5bad65906d24ea4948de93e1d4d0280 SHA512 62a08b286313234c4c3226872a410afe9818c829fb3424f4c2a464f759d8d3c6a701de4a89ea21fe6ac2b9620cec0a44c04dd5a793ba30a0537ed3ddf86fff46
+DIST rocm-comgr-3.8.0.tar.gz 95949 BLAKE2B af6f4f2961e0476be8aedae14fc7b3406cdd63759f456faa9c608c68a0c9578d5ad356b11713c1f5b943374f17ebfa043ee5294d3fb6f1a0047639136bc8b565 SHA512 5855825b24fffb3b503a0e2b6bd66a159b6b75a32902e9a428a3be0fa01d8b0c0b6e658c3f5b1520bf79e0dfd20cd453afb3d83d9946387f0ec636378f5129c6
diff --git a/dev-libs/rocm-comgr/rocm-comgr-3.8.0.ebuild b/dev-libs/rocm-comgr/rocm-comgr-3.8.0.ebuild
new file mode 100644
index 000000000000..097011983ea2
--- /dev/null
+++ b/dev-libs/rocm-comgr/rocm-comgr-3.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/lib/comgr"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-CompilerSupport-rocm-${PV}/lib/comgr"
+ KEYWORDS="~amd64"
+fi
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.1.0-dependencies.patch"
+)
+
+DESCRIPTION="Radeon Open Compute Code Object Manager"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocm-device-libs-${PV}
+ >=sys-devel/llvm-roc-${PV}:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/llvm"
+ -DClang_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/clang"
+ )
+ cmake_src_configure
+}