summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-06 12:09:13 +0100
committerSam James <sam@gentoo.org>2024-08-06 12:09:13 +0100
commita96a616ddf52518754b62219309d1d289795d803 (patch)
tree1268859d81683ffaeb1391d5710a866e82a1adbe /dev-libs
parentdev-libs/keystone: enable py3.13 (diff)
downloadgentoo-a96a616ddf52518754b62219309d1d289795d803.tar.gz
gentoo-a96a616ddf52518754b62219309d1d289795d803.tar.bz2
gentoo-a96a616ddf52518754b62219309d1d289795d803.zip
dev-libs/keystone: fix build w/ gcc-15
I admit I haven't sent this upstream as upstream don't seem to be merging many PRs at the moment and it's also in some ancient copy of bundled LLVM. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/keystone/files/keystone-0.9.2-gcc15-cstdint.patch10
-rw-r--r--dev-libs/keystone/keystone-0.9.2-r3.ebuild1
2 files changed, 11 insertions, 0 deletions
diff --git a/dev-libs/keystone/files/keystone-0.9.2-gcc15-cstdint.patch b/dev-libs/keystone/files/keystone-0.9.2-gcc15-cstdint.patch
new file mode 100644
index 000000000000..ba053db30040
--- /dev/null
+++ b/dev-libs/keystone/files/keystone-0.9.2-gcc15-cstdint.patch
@@ -0,0 +1,10 @@
+--- a/llvm/include/llvm/ADT/STLExtras.h
++++ b/llvm/include/llvm/ADT/STLExtras.h
+@@ -21,6 +21,7 @@
+ #include <algorithm> // for std::all_of
+ #include <cassert>
+ #include <cstddef> // for std::size_t
++#include <cstdint>
+ #include <cstdlib> // for qsort
+ #include <functional>
+ #include <iterator>
diff --git a/dev-libs/keystone/keystone-0.9.2-r3.ebuild b/dev-libs/keystone/keystone-0.9.2-r3.ebuild
index 3ac8106f976a..b6d645b0d8ee 100644
--- a/dev-libs/keystone/keystone-0.9.2-r3.ebuild
+++ b/dev-libs/keystone/keystone-0.9.2-r3.ebuild
@@ -50,6 +50,7 @@ REQUIRED_USE="
PATCHES=(
"${FILESDIR}/${P}-strict-prototypes.patch"
+ "${FILESDIR}/${PN}-0.9.2-gcc15-cstdint.patch"
)
# Upstream doesn't flag patch releases (bug 858395)