summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-11-24 15:17:48 +0000
committerDavid Seifert <soap@gentoo.org>2018-11-24 20:26:27 +0100
commit9c1c90cf0f8507cd5f9da6c9db68deb90d429b2d (patch)
treebf0a601ded4c649eccabfdb3068807789313d433 /dev-libs
parentdev-util/uncrustify: version bump (diff)
downloadgentoo-9c1c90cf0f8507cd5f9da6c9db68deb90d429b2d.tar.gz
gentoo-9c1c90cf0f8507cd5f9da6c9db68deb90d429b2d.tar.bz2
gentoo-9c1c90cf0f8507cd5f9da6c9db68deb90d429b2d.zip
dev-libs/boost: backport spsc_queue.hpp include fix
Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/671724 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/boost-1.67.0-r1.ebuild (renamed from dev-libs/boost/boost-1.67.0.ebuild)3
-rw-r--r--dev-libs/boost/files/boost-1.67.0-lockfree-next.patch24
2 files changed, 26 insertions, 1 deletions
diff --git a/dev-libs/boost/boost-1.67.0.ebuild b/dev-libs/boost/boost-1.67.0-r1.ebuild
index 7eb5c945be41..1c9de953032d 100644
--- a/dev-libs/boost/boost-1.67.0.ebuild
+++ b/dev-libs/boost/boost-1.67.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,6 +49,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.55.0-context-x32.patch"
"${FILESDIR}/${PN}-1.56.0-build-auto_index-tool.patch"
"${FILESDIR}/${PN}-1.67.0-fix-python.patch"
+ "${FILESDIR}/${PN}-1.67.0-lockfree-next.patch"
)
python_bindings_needed() {
diff --git a/dev-libs/boost/files/boost-1.67.0-lockfree-next.patch b/dev-libs/boost/files/boost-1.67.0-lockfree-next.patch
new file mode 100644
index 000000000000..acf9a96777e5
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.67.0-lockfree-next.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/671724
+
+From 12726cda009a855073b9bedbdce57b6ce7763da2 Mon Sep 17 00:00:00 2001
+From: Peter Dimov <pdimov@pdimov.com>
+Date: Sat, 2 Dec 2017 04:10:46 +0200
+Subject: [PATCH] Add #include <boost/next_prior.hpp>; no longer in utility.hpp
+
+---
+ include/boost/lockfree/spsc_queue.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/boost/lockfree/spsc_queue.hpp
++++ b/boost/lockfree/spsc_queue.hpp
+@@ -17,6 +17,7 @@
+ #include <boost/assert.hpp>
+ #include <boost/static_assert.hpp>
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+ #include <boost/utility/enable_if.hpp>
+ #include <boost/config.hpp> // for BOOST_LIKELY
+
+--
+2.19.2
+