summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Judt <h.judt@gmx.at>2019-11-13 21:07:02 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-12-13 15:48:51 +0200
commit67373951aeb902dbe5a424698c7c024e69ce3832 (patch)
tree0da47ad7afcb866e2b9f01c580c9325651196b89 /dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild
parentdev-lisp/c2ffi: Remove c2ffi-8.0.0.9999.ebuild (diff)
downloadgentoo-67373951aeb902dbe5a424698c7c024e69ce3832.tar.gz
gentoo-67373951aeb902dbe5a424698c7c024e69ce3832.tar.bz2
gentoo-67373951aeb902dbe5a424698c7c024e69ce3832.zip
dev-lisp/c2ffi: Version bump to c2ffi-9.0.0
Bump to use c2ffi-9.0.0 branch. At the moment, we need to supply our own patch to get it building, though the issue has been reported upstream and a pull request has been sent: https://github.com/rpav/c2ffi/issues/71 https://github.com/rpav/c2ffi/pull/70 This commit additionally provides a snapshot build because live-only packages are not allowed. Additionally, multi-slot has been removed. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Harald Judt <h.judt@gmx.at> Closes: https://github.com/gentoo/gentoo/pull/13620 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild b/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild
new file mode 100644
index 000000000000..4f2748bb7f4c
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils llvm
+
+MY_COMMIT="15fda06de0bad97bf91f5590f7f24623eab2f580"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-devel/clang:9=
+ sys-devel/llvm:9=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${PN}-9.0.0.20191017-fix-lib-location.patch )