summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/lua-zlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/lua-zlib')
-rw-r--r--dev-lua/lua-zlib/Manifest2
-rw-r--r--dev-lua/lua-zlib/lua-zlib-0.3.ebuild32
-rw-r--r--dev-lua/lua-zlib/lua-zlib-0.4.ebuild32
-rw-r--r--dev-lua/lua-zlib/metadata.xml11
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-lua/lua-zlib/Manifest b/dev-lua/lua-zlib/Manifest
new file mode 100644
index 000000000000..d68f94d5490b
--- /dev/null
+++ b/dev-lua/lua-zlib/Manifest
@@ -0,0 +1,2 @@
+DIST lua-zlib-0.3.tgz 11220 SHA256 c7d687e9fddc0a094cb47587e50bebf9fd632bf72f74b61b2dcf1a37dd8c4b3a SHA512 99711166637d394c806dd16b86a3588ff84eb9180d2da05725ff6d4e86458d1ded7a5fbb303284fa442fd0925bc94fe34772057e0190c1a3e00cbb853865941d WHIRLPOOL 6735aad7e34ca1b19548e2c130c02807e269329f3296664a5bf18577e678304b5a20040358966eed6b9c3a94756df5e82ffa878df956982effd3d1e447b1b643
+DIST lua-zlib-0.4.tgz 11257 SHA256 dba2590cae117f8ba1bc94319ac159cbeeddb3f9715d1528b982460721097178 SHA512 1c28be12b000cb729a82336a4cfc6d2f7367b2fb9941bd200d2aab561f51715f02b54858d38b3d1a65eced81d31d932dc45d214e3410e7f313238fddf5766a3a WHIRLPOOL 418a5afef4ff5b6ba49a3cb10c79a46f3d1e8aa472fb701d8d5a0e6238b2fddcb350bd25d3dafa9839909596458581f7dd9dcd1e6de852bab44046a563ba3619
diff --git a/dev-lua/lua-zlib/lua-zlib-0.3.ebuild b/dev-lua/lua-zlib/lua-zlib-0.3.ebuild
new file mode 100644
index 000000000000..02424a57d00b
--- /dev/null
+++ b/dev-lua/lua-zlib/lua-zlib-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Lua bindings to zlib"
+HOMEPAGE="http://github.com/brimworks/lua-zlib"
+SRC_URI="https://github.com/brimworks/${PN}/tarball/v${PV} -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_configure() {
+ MYCMAKEARGS="-DINSTALL_CMOD='$(pkg-config --variable INSTALL_CMOD lua)'"
+ cmake-utils_src_configure
+}
diff --git a/dev-lua/lua-zlib/lua-zlib-0.4.ebuild b/dev-lua/lua-zlib/lua-zlib-0.4.ebuild
new file mode 100644
index 000000000000..ade32f1e3de7
--- /dev/null
+++ b/dev-lua/lua-zlib/lua-zlib-0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Lua bindings to zlib"
+HOMEPAGE="http://github.com/brimworks/lua-zlib"
+SRC_URI="https://github.com/brimworks/${PN}/tarball/v${PV} -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_configure() {
+ MYCMAKEARGS="-DINSTALL_CMOD='$(pkg-config --variable INSTALL_CMOD lua)'"
+ cmake-utils_src_configure
+}
diff --git a/dev-lua/lua-zlib/metadata.xml b/dev-lua/lua-zlib/metadata.xml
new file mode 100644
index 000000000000..febdce9d3607
--- /dev/null
+++ b/dev-lua/lua-zlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">brimworks/lua-zlib</remote-id>
+ </upstream>
+</pkgmetadata>