summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:24:39 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:43 +0100
commita2110cab10b83eac93ff358cdd8124718093360f (patch)
treeea79e03cda5916201c833e1a5b4a4ede1e8d8d8d /dev-lua
parentdev-lua/lua_cliargs: drop 3.0_p2-r100 (diff)
downloadgentoo-a2110cab10b83eac93ff358cdd8124718093360f.tar.gz
gentoo-a2110cab10b83eac93ff358cdd8124718093360f.tar.bz2
gentoo-a2110cab10b83eac93ff358cdd8124718093360f.zip
dev-lua/luacheck: add 0.25.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luacheck/Manifest1
-rw-r--r--dev-lua/luacheck/luacheck-0.25.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-lua/luacheck/Manifest b/dev-lua/luacheck/Manifest
index c45ea5927c70..592147c077a7 100644
--- a/dev-lua/luacheck/Manifest
+++ b/dev-lua/luacheck/Manifest
@@ -1 +1,2 @@
DIST luacheck-0.24.0.tar.gz 162474 BLAKE2B 6ec2b35deb2f0e5dacbe00e9d5adda7a1d66ee55475adf2b40cfff4d876cd44c9aec762e52bf02bb6f65cccc7c42203d94d3c9ed7a9f2311b3b7ae7bf8ab09e0 SHA512 759079d4a033c8af1d7c314f39bb75398b8ad89b627eaf8b60cf0a878c3ea86bd5e8993ad3d564746614b06b93b4100f016fdcb805d02b226e8e1e5b4c81c6d2
+DIST luacheck-0.25.0.tar.gz 162675 BLAKE2B 143de767f004cb485abc4952eafc4d02c16ca4d421397d0179113ddaeacc2cd7ba2b4b8eed48f9a05169c5e20ae53aaef8c5253ab1d7c7e4b178218fab0e03d6 SHA512 7f9f02464cb40462c321dd23e32263913ead2bf4eace6907d51a5b570a6a19a378b12660c98e63ca447cfc507dfb491d54b093af3962f12596a7c6088c8dc867
diff --git a/dev-lua/luacheck/luacheck-0.25.0.ebuild b/dev-lua/luacheck/luacheck-0.25.0.ebuild
new file mode 100644
index 000000000000..29d6bb441a37
--- /dev/null
+++ b/dev-lua/luacheck/luacheck-0.25.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A tool for linting and static analysis of Lua code"
+HOMEPAGE="https://github.com/luarocks/luacheck"
+SRC_URI="https://github.com/luarocks/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lua/lua-argparse[${LUA_USEDEP}]
+ dev-lua/lua-utf8[${LUA_USEDEP}]
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-lua/busted[${LUA_USEDEP}]
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.23.0-disable-measuring-performance-test.patch" )
+
+src_compile() {
+ if use doc; then
+ sphinx-build docsrc html || die
+ fi
+}
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r src/luacheck
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ newbin bin/luacheck.lua luacheck
+
+ use doc && local -a HTML_DOCS=( "html/." )
+ einstalldocs
+}