summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-06 15:19:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-06 15:26:04 +0200
commit4bdf4b4496195ba2fcd9bab588f462ddbc6590c3 (patch)
treec9eebd58f77de301e70d1b2a0e11bf09020a12c6 /dev-ml/ocaml-dns/ocaml-dns-0.18.1.ebuild
parentdev-ml/camlimages: bump to 4.2.2 (diff)
downloadgentoo-4bdf4b4496195ba2fcd9bab588f462ddbc6590c3.tar.gz
gentoo-4bdf4b4496195ba2fcd9bab588f462ddbc6590c3.tar.bz2
gentoo-4bdf4b4496195ba2fcd9bab588f462ddbc6590c3.zip
dev-ml/ocaml-dns: bump to 0.18.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ml/ocaml-dns/ocaml-dns-0.18.1.ebuild')
-rw-r--r--dev-ml/ocaml-dns/ocaml-dns-0.18.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dns/ocaml-dns-0.18.1.ebuild b/dev-ml/ocaml-dns/ocaml-dns-0.18.1.ebuild
new file mode 100644
index 000000000000..c0c9038faed9
--- /dev/null
+++ b/dev-ml/ocaml-dns/ocaml-dns-0.18.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt"
+
+RDEPEND="
+ async? ( >=dev-ml/async-112.24.00:= )
+ lwt? ( >=dev-ml/lwt-2.4.7:=
+ dev-ml/ocaml-cstruct:=[lwt(-)] )
+ >=dev-lang/ocaml-4:=
+ dev-ml/cmdliner:=
+ dev-ml/mirage-profile:=
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-1.9.0:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ dev-ml/ocaml-hashcons:=[ocamlopt?]
+ !<dev-ml/mirage-types-1.2.0
+ !dev-ml/odns
+"
+DEPEND="
+ test? ( dev-ml/ounit
+ dev-ml/ocaml-pcap )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable async)
+ $(use_enable lwt)
+ $(use_enable test nettests)
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )