summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 11:21:40 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 11:55:32 +0100
commitcb3456e5d3fbc0439e58ab6cf050260f60cedc79 (patch)
treeb31b935f63fe8104bfaf33568253773e7824d845 /dev-ml/result/result-1.2.ebuild
parentdev-python/cryptography-vectors: ia64 stable wrt bug #574150 (diff)
downloadgentoo-cb3456e5d3fbc0439e58ab6cf050260f60cedc79.tar.gz
gentoo-cb3456e5d3fbc0439e58ab6cf050260f60cedc79.tar.bz2
gentoo-cb3456e5d3fbc0439e58ab6cf050260f60cedc79.zip
dev-ml/result: initial import; ebuild by me
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/result/result-1.2.ebuild')
-rw-r--r--dev-ml/result/result-1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/result/result-1.2.ebuild b/dev-ml/result/result-1.2.ebuild
new file mode 100644
index 000000000000..4b8085ae52b7
--- /dev/null
+++ b/dev-ml/result/result-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Compat result type"
+HOMEPAGE="https://github.com/janestreet/result"
+SRC_URI="https://github.com/janestreet/result/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md
+}