summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-21 21:21:54 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-21 21:22:23 +0100
commit41fc94fab5b7746147bcaf9056e77979e6c86ab7 (patch)
treec2628746a2c728bf13619ca13c447d1de1343eab /dev-ml/xmlm
parentdev-python/setuptools: Add a patch to disable trove-classifier use (diff)
downloadgentoo-41fc94fab5b7746147bcaf9056e77979e6c86ab7.tar.gz
gentoo-41fc94fab5b7746147bcaf9056e77979e6c86ab7.tar.bz2
gentoo-41fc94fab5b7746147bcaf9056e77979e6c86ab7.zip
dev-ml/xmlm: new package, add 1.4.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/xmlm')
-rw-r--r--dev-ml/xmlm/Manifest1
-rw-r--r--dev-ml/xmlm/metadata.xml15
-rw-r--r--dev-ml/xmlm/xmlm-1.4.0.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/xmlm/Manifest b/dev-ml/xmlm/Manifest
new file mode 100644
index 000000000000..fa2717989f7c
--- /dev/null
+++ b/dev-ml/xmlm/Manifest
@@ -0,0 +1 @@
+DIST xmlm-1.4.0.tbz 26122 BLAKE2B dcc75836199eeca49967c4245b793b612c3ac83677dc4185d956437af63802759cc99190ad3ad036227706b4ecd4af938ed76d2f049b1273e81bf13b79e6316b SHA512 69f6112e6466952256d670fe1751fe4ae79e20d50f018ece1709eb2240cb1b00968ac7cee110771e0617a38ebc1cdb43e9d146471ce66ac1b176e4a1660531eb
diff --git a/dev-ml/xmlm/metadata.xml b/dev-ml/xmlm/metadata.xml
new file mode 100644
index 000000000000..67210967211e
--- /dev/null
+++ b/dev-ml/xmlm/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">
+ Xmlm is a streaming codec to decode and encode the XML data format.
+ It can process XML documents without a complete in-memory
+ representation of the data.
+ Xmlm is made of a single independent module and distributed under the
+ ISC license.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/xmlm/xmlm-1.4.0.ebuild b/dev-ml/xmlm/xmlm-1.4.0.ebuild
new file mode 100644
index 000000000000..214b47efdccf
--- /dev/null
+++ b/dev-ml/xmlm/xmlm-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit opam
+
+DESCRIPTION="Streaming XML codec for OCaml"
+HOMEPAGE="https://erratique.ch/software/xmlm"
+SRC_URI="https://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}