summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-16 15:49:12 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-16 23:49:49 +0100
commit5acf71570047bef8f0016922e8efa15e14bcea6a (patch)
tree11c60bfc8342ac895af6871d56f41b9a3ab06209 /dev-perl/Test-MockRandom/Test-MockRandom-1.10.0.ebuild
parentdev-perl/Path-Class: Bump to version 0.360.0 (diff)
downloadgentoo-5acf71570047bef8f0016922e8efa15e14bcea6a.tar.gz
gentoo-5acf71570047bef8f0016922e8efa15e14bcea6a.tar.bz2
gentoo-5acf71570047bef8f0016922e8efa15e14bcea6a.zip
dev-perl/Test-MockRandom: Added to tree at version 1.10.0
Added for dev-perl/Path-Tiny-0.84.0 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Test-MockRandom/Test-MockRandom-1.10.0.ebuild')
-rw-r--r--dev-perl/Test-MockRandom/Test-MockRandom-1.10.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Test-MockRandom/Test-MockRandom-1.10.0.ebuild b/dev-perl/Test-MockRandom/Test-MockRandom-1.10.0.ebuild
new file mode 100644
index 000000000000..5875e59a6f8c
--- /dev/null
+++ b/dev-perl/Test-MockRandom/Test-MockRandom-1.10.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Replaces random number generation with non-random number generation"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal examples"
+
+RDEPEND="
+ virtual/perl-Carp
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ !minimal? (
+ virtual/perl-CPAN-Meta
+ >=virtual/perl-CPAN-Meta-Requirements-2.120.900
+ )
+ virtual/perl-File-Spec
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple
+ virtual/perl-version
+ )
+"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples/
+ dodoc -r examples/*
+ fi
+}