summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:15:16 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:21:06 -0500
commit5a3b26f0fd67da0b3a2814c47d0471b551bc794b (patch)
tree42cbab3a7c3e7748900f9ee1534ca1abcfb20324 /dev-php/sebastian-version/sebastian-version-2.0.1.ebuild
parentdev-php/webmozart-assert: New package for an unbundled phpunit (diff)
downloadgentoo-5a3b26f0fd67da0b3a2814c47d0471b551bc794b.tar.gz
gentoo-5a3b26f0fd67da0b3a2814c47d0471b551bc794b.tar.bz2
gentoo-5a3b26f0fd67da0b3a2814c47d0471b551bc794b.zip
dev-php/sebastian-version: New package for an unbundled phpunit
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php/sebastian-version/sebastian-version-2.0.1.ebuild')
-rw-r--r--dev-php/sebastian-version/sebastian-version-2.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-version/sebastian-version-2.0.1.ebuild b/dev-php/sebastian-version/sebastian-version-2.0.1.ebuild
new file mode 100644
index 000000000000..87a7bded342e
--- /dev/null
+++ b/dev-php/sebastian-version/sebastian-version-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="version"
+
+DESCRIPTION="Helps with managing the version number of Git-hosted PHP projects"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann
+ doins src/Version.php
+ insinto /usr/share/php/SebastianBergmann/Version
+ doins "${FILESDIR}/autoload.php"
+}