summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 14:28:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 14:52:25 +0200
commit370ec95cad5b06f3c49fd523599e4a9648abdd07 (patch)
tree8fdbd5bdf4ab6304ac37c8f8b43fb58c7292ecd9 /dev-python/apache-libcloud
parentdev-python/libcloud: Prepare for rename (diff)
downloadgentoo-370ec95cad5b06f3c49fd523599e4a9648abdd07.tar.gz
gentoo-370ec95cad5b06f3c49fd523599e4a9648abdd07.tar.bz2
gentoo-370ec95cad5b06f3c49fd523599e4a9648abdd07.zip
Rename dev-python/{libcloud → apache-libcloud}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apache-libcloud')
-rw-r--r--dev-python/apache-libcloud/Manifest1
-rw-r--r--dev-python/apache-libcloud/apache-libcloud-3.7.0.ebuild61
-rw-r--r--dev-python/apache-libcloud/metadata.xml13
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/apache-libcloud/Manifest b/dev-python/apache-libcloud/Manifest
new file mode 100644
index 000000000000..7da391086683
--- /dev/null
+++ b/dev-python/apache-libcloud/Manifest
@@ -0,0 +1 @@
+DIST apache-libcloud-3.7.0.tar.bz2 1979020 BLAKE2B f8630a5c559cba9ae6f7792ffc9cf4ba6eb2fdaa28d6ae148a5d2e978ee66eec9a39b16741446b78b047bf2454de860148a13bce3dbd8627dbc7dac43543b808 SHA512 315866947d2c748e4a13c4c2a4147a2a8e79cbb85e9e83fded3f89ff8a50c531acf1062a4e21c61448c20e7f7e7f9d1317d3c43ecfe2fb75155c0d81ff03f889
diff --git a/dev-python/apache-libcloud/apache-libcloud-3.7.0.ebuild b/dev-python/apache-libcloud/apache-libcloud-3.7.0.ebuild
new file mode 100644
index 000000000000..70d98b326d97
--- /dev/null
+++ b/dev-python/apache-libcloud/apache-libcloud-3.7.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+MY_P=apache-libcloud-${PV}
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="https://libcloud.apache.org/"
+SRC_URI="mirror://apache/libcloud/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-2.6.1[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs network access
+ libcloud/test/compute/test_ovh.py::OvhTests::test_list_nodes_invalid_region
+ libcloud/test/test_connection.py::BaseConnectionClassTestCase::test_connection_timeout_raised
+ libcloud/test/test_connection.py::ConnectionClassTestCase::test_retry_on_all_default_retry_exception_classes
+ # TODO
+ libcloud/test/compute/test_ssh_client.py::ParamikoSSHClientTests::test_key_file_non_pem_format_error
+)
+
+src_prepare() {
+ if use examples; then
+ mkdir examples || die
+ mv example_*.py examples || die
+ fi
+
+ # needed for tests
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ use examples && dodoc -r examples
+ distutils-r1_src_install
+}
diff --git a/dev-python/apache-libcloud/metadata.xml b/dev-python/apache-libcloud/metadata.xml
new file mode 100644
index 000000000000..ef0cc22c1151
--- /dev/null
+++ b/dev-python/apache-libcloud/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">apache/libcloud</remote-id>
+ <remote-id type="pypi">apache-libcloud</remote-id>
+ </upstream>
+</pkgmetadata>