summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-12-13 18:45:35 -0500
committerTim Harder <radhermit@gentoo.org>2015-12-13 18:56:58 -0500
commite0989afe381c734a7eeec6cdb1efa0a425bbbca5 (patch)
treef1fe731db157622f0859bd5af0e88eb7c6f6fe20 /dev-python/bleach/bleach-1.4.2.ebuild
parentx11-wm/page: List libraries in RDEPEND and the rest in DEPEND. Fixes bug 562632. (diff)
downloadgentoo-e0989afe381c734a7eeec6cdb1efa0a425bbbca5.tar.gz
gentoo-e0989afe381c734a7eeec6cdb1efa0a425bbbca5.tar.bz2
gentoo-e0989afe381c734a7eeec6cdb1efa0a425bbbca5.zip
dev-python/bleach: version bump to 1.4.2
Diffstat (limited to 'dev-python/bleach/bleach-1.4.2.ebuild')
-rw-r--r--dev-python/bleach/bleach-1.4.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/bleach/bleach-1.4.2.ebuild b/dev-python/bleach/bleach-1.4.2.ebuild
new file mode 100644
index 000000000000..56945ff80b4b
--- /dev/null
+++ b/dev-python/bleach/bleach-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/jsocol/bleach https://pypi.python.org/pypi/bleach"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/html5lib-0.999[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/nose-1.3[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}