summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 07:32:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 08:43:58 +0100
commit15116c26feeec5b3c036005ddb308fd9d7374e9f (patch)
tree815763dc83f75b180e4df11dbc3e5513bb86546f /dev-python/boto3
parentdev-python/botocore: Bump to 1.33.2 (diff)
downloadgentoo-15116c26feeec5b3c036005ddb308fd9d7374e9f.tar.gz
gentoo-15116c26feeec5b3c036005ddb308fd9d7374e9f.tar.bz2
gentoo-15116c26feeec5b3c036005ddb308fd9d7374e9f.zip
dev-python/boto3: Bump to 1.33.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.33.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 179b3e0a02ff..d3d2917bde2a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.29.3.gh.tar.gz 737012 BLAKE2B 4282de0bbe03b61cf6884b08cf0a16e93c1e2
DIST boto3-1.29.6.gh.tar.gz 738684 BLAKE2B a42245ddc7a0f31329057016f47739fc4071a030dca1ced347b447860e9397e3c8bae8c70ca86629a4b6b3f403ed845887340e6aeb08fe33c006dea9cd3f6317 SHA512 551a3568f3ceb1f37c7d209e7aa011dbd87d01e02f7559f15563bbd06da6d7a1ff79a1a5ed8150cfbc183cd1c56041a1e36753939142962f056348362665c118
DIST boto3-1.33.0.gh.tar.gz 748113 BLAKE2B 0db5a6b8bfb10854374b178c885a8e8383a65de659afe9c60a0f65bd32920d25c7021fff271cba3ea4408c7dcd519a180cc38b4b1e218e313882da7ab7a7cdaa SHA512 f10edde8257c315521f54e0eb821a09071c767b09e6c3f95496f6e611af1a741489e8f6c3293ca7da48f2cb8c1262770480fbb38016ddad5f15965e9f842d7e7
DIST boto3-1.33.1.gh.tar.gz 748452 BLAKE2B 59e7c28d59c69e6ab440740e85f6ed016d1df7078635cfab4616095182f4ad7bba5bcc01a9484f97a8a0388f2ac5d9b53ab595431a8117f9d4731954df63149f SHA512 95996e4005d33e85de8f15889e69c4725943b5a0dd74ee97ae82c282b9da68cdbfcbd494b66c4adca5b530eefbe5505b963f9fcb9e97bd78bc74525c78708818
+DIST boto3-1.33.2.gh.tar.gz 749706 BLAKE2B b83b6bfc2953c5d353e9e245da99deea9e6428c8c5e3fa3041a249b2a34981b329ef7a2fbf272066b2a11c8bb707c9a5e1e2b040e070958062080979a1bd0a16 SHA512 245343fb8a3f5adacfa4b379152feff70adc7d99487dae1cc793f5531f83cd06b7ef40200b9dcac91ad936113a13dbe6cdf1add2b4b94922a83d3e979a226698
diff --git a/dev-python/boto3/boto3-1.33.2.ebuild b/dev-python/boto3/boto3-1.33.2.ebuild
new file mode 100644
index 000000000000..28ca44b536aa
--- /dev/null
+++ b/dev-python/boto3/boto3-1.33.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.8.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}