summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-03 07:13:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-03 08:48:14 +0200
commitc7f27a323492137499a11dd19b90e83adf42d113 (patch)
tree6eba58f0b617b3465c810f20e2b67ab5503aaf38 /dev-python/botocore
parentdistutils-r1.eclass: drop dead prefix targets (diff)
downloadgentoo-c7f27a323492137499a11dd19b90e83adf42d113.tar.gz
gentoo-c7f27a323492137499a11dd19b90e83adf42d113.tar.bz2
gentoo-c7f27a323492137499a11dd19b90e83adf42d113.zip
dev-python/botocore: Bump to 1.29.146
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.146.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 496ae1e5c277..6968d46e4f41 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.29.142.gh.tar.gz 11528069 BLAKE2B 860a5ab68d26424702006b221e62e2
DIST botocore-1.29.143.gh.tar.gz 11539133 BLAKE2B f1845154fe406cbc06fdbaa1bf8f48a98b40f267a59b86b9574955da9ad9d01c8eb573327ff1f1e68c06682ab2068328dc3bf8cf3cfe0df277a13afe51c70a50 SHA512 647301c2570f214493a934e0deb516a3b08b1bca34b71dff1a068c67427eaaeb371894f651cfb7152e23a31f91a63af3f25f47c198b5c6b65113eb648ee0b3d6
DIST botocore-1.29.144.gh.tar.gz 11545575 BLAKE2B cda5a1c91b44218d43a4f06f6f68ae44cad4d1ba0ff4b88a168642bf7f8be7f2a627acba2375c9d8dbc1b5648d71dba4e37a2da5dd9ce8845dd0ee716504ecbf SHA512 ddd3e8dbe334d663012e92c2839f91387751aa7a69b3bdf1331ae25f145700c26e1c62e4b3a8bb913afb38f11d02b5c0da34fdd5d45a97898bcd0b468163a4be
DIST botocore-1.29.145.gh.tar.gz 11552372 BLAKE2B 1535d0535719d0d2efae25fb9f2220a7381c6a6a5ee31e6ebd45c14b80c122c703bf9395f5a215a6fa671dd983b58ab4a9e5c6ce2a5bc429d5944df2319ce9a8 SHA512 d6d4a57cb552d496b81ae24fdc5d777d25c5d75781cad89814f86618e591717feae62b43342b82aa9550e0e42b7b50dd52b6ec82a06794f5f46f0751aaabc31b
+DIST botocore-1.29.146.gh.tar.gz 11553866 BLAKE2B 7b5b060480de459af9045be8724272fb876c8663b39b1a1ea3575cee83d233dc4e04735682f7eac9299ae0219a5995ddd3379d75c6d2e1bece565e2294b3cc23 SHA512 e786137deaac49fa9db7c8c4df1ff8be195dd400432fbb2e6a23608181161234fa5c3a81a293b4ae1133d1a40e0341b3a081f0d845672e8d0c604fdffc2bc1b5
diff --git a/dev-python/botocore/botocore-1.29.146.ebuild b/dev-python/botocore/botocore-1.29.146.ebuild
new file mode 100644
index 000000000000..3ced99abe4ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.146.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ # urllib3-2 compatibility, mock relies on implementation details
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_no_response_from_server
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_returned
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_sends_307
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_sends_connection_header
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_handles_expect_100_with_different_reason_phrase
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_state_reset_on_connection_close
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}