summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-14 20:25:06 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-14 20:25:06 -0400
commitb52d9b6f12c3d6e1e1e4300fd6a4c305608ace19 (patch)
tree4d1a4201e29d4caebb4e4af3834cada73a20c664 /dev-python/columnize/columnize-0.3.9.ebuild
parentdev-python/cffi: version bump to 1.8.2 (diff)
downloadgentoo-b52d9b6f12c3d6e1e1e4300fd6a4c305608ace19.tar.gz
gentoo-b52d9b6f12c3d6e1e1e4300fd6a4c305608ace19.tar.bz2
gentoo-b52d9b6f12c3d6e1e1e4300fd6a4c305608ace19.zip
dev-python/columnize: version bump to 0.3.9
Diffstat (limited to 'dev-python/columnize/columnize-0.3.9.ebuild')
-rw-r--r--dev-python/columnize/columnize-0.3.9.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/columnize/columnize-0.3.9.ebuild b/dev-python/columnize/columnize-0.3.9.ebuild
new file mode 100644
index 000000000000..c61bc55fd0a5
--- /dev/null
+++ b/dev-python/columnize/columnize-0.3.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format a simple (i.e. not nested) list into aligned columns"
+HOMEPAGE="https://github.com/rocky/pycolumnize https://pypi.python.org/pypi/columnize"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"