summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 07:51:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 09:49:25 +0100
commitf4710866624fae4ae2cd7515c6c87f1035a42cf2 (patch)
tree897caaf8f0ed6363c0368d22e1a4d80a3e6d3983 /dev-python/dep-logic
parentdev-python/keystoneauth1: Bump to 5.6.0 (diff)
downloadgentoo-f4710866624fae4ae2cd7515c6c87f1035a42cf2.tar.gz
gentoo-f4710866624fae4ae2cd7515c6c87f1035a42cf2.tar.bz2
gentoo-f4710866624fae4ae2cd7515c6c87f1035a42cf2.zip
dev-python/dep-logic: Bump to 0.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dep-logic')
-rw-r--r--dev-python/dep-logic/Manifest1
-rw-r--r--dev-python/dep-logic/dep-logic-0.2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/dep-logic/Manifest b/dev-python/dep-logic/Manifest
index 8e4bf80d36db..8c43d3dfdf4a 100644
--- a/dev-python/dep-logic/Manifest
+++ b/dev-python/dep-logic/Manifest
@@ -1,2 +1,3 @@
DIST dep_logic-0.0.4.tar.gz 27197 BLAKE2B e7047c767a0c29f05975c53da0bd0ef1232abef7f34cf6430a877251a56af7fff7e3a11c28781d74d32436ef0d5ce6647356f9ebc35b2fb925333ed4d973830f SHA512 fc2d300f1a71a751cb2d983cd25251b4cfe4cf2f61397625cadaf8d528d4ca4a393714cce3fc970665c278f6711aedba936c07050d458f4111280a4031ad9edb
DIST dep_logic-0.1.0.tar.gz 27758 BLAKE2B 89b81f5e8fcafef6f36fc95cd810a787d76cf2fa28a077beffb3396a5ef95d3993141300102e0a1360335ff3e697c58b707479c6314ac1e8657b6155f1c270b8 SHA512 eb06c6f480d306b5f45fe16ca0b452a1a6dd6318726b713e78c4be970cbd5d243e75e0850e2ff23d490c4291f8ae05442a550fda6135dc2007db1083d9f80128
+DIST dep_logic-0.2.0.tar.gz 27758 BLAKE2B c1895fb20468046a73dfed686713b67de8238f026f6c31997b4d7740dc2fa882e86120301b0fe860066bd14fa4491f8b135631e4a72eb2aa5abe1fe4165ce64d SHA512 c3685a540f210a8007375484bd4cea63b16a8cd3bcfab1cee250eb94136104ccc847872cfe78f694c843c30517f298ada18fcdbd2673fd130b4edc4e8df9052b
diff --git a/dev-python/dep-logic/dep-logic-0.2.0.ebuild b/dev-python/dep-logic/dep-logic-0.2.0.ebuild
new file mode 100644
index 000000000000..58158724015e
--- /dev/null
+++ b/dev-python/dep-logic/dep-logic-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python dependency specifications supporting logical operations"
+HOMEPAGE="
+ https://github.com/pdm-project/dep-logic/
+ https://pypi.org/project/dep-logic/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/packaging-22[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest