summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-21 09:40:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-21 10:08:15 +0200
commit5a0d4858f589cf1e883737270043de9ae216e723 (patch)
tree55ee21204473a5c7f8dbd87f39b4bb6a8401b6db /dev-python/discogs-client/discogs-client-2.2.2.ebuild
parentdev-python/discogs-client: Enable py3.{7,8} (diff)
downloadgentoo-5a0d4858f589cf1e883737270043de9ae216e723.tar.gz
gentoo-5a0d4858f589cf1e883737270043de9ae216e723.tar.bz2
gentoo-5a0d4858f589cf1e883737270043de9ae216e723.zip
dev-python/discogs-client: Bump to 2.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/discogs-client/discogs-client-2.2.2.ebuild')
-rw-r--r--dev-python/discogs-client/discogs-client-2.2.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/discogs-client/discogs-client-2.2.2.ebuild b/dev-python/discogs-client/discogs-client-2.2.2.ebuild
new file mode 100644
index 000000000000..ce9a90a9447b
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Python API client for Discogs"
+HOMEPAGE="https://github.com/discogs/discogs_client https://pypi.org/project/discogs-client/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ "
+
+distutils_enable_tests unittest