summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-05 19:49:16 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-05 20:45:03 +0100
commit548d586ed738ba389b041d440ca93c58d1e60fc9 (patch)
treee6a5d6a28debab0425cd78e43619eb884e1cad0f /dev-python/ed25519ll
parentdev-python/keyrings_alt: New package, ebuild written by me (diff)
downloadgentoo-548d586ed738ba389b041d440ca93c58d1e60fc9.tar.gz
gentoo-548d586ed738ba389b041d440ca93c58d1e60fc9.tar.bz2
gentoo-548d586ed738ba389b041d440ca93c58d1e60fc9.zip
dev-python/ed25519ll: New package, ebuild written by me
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ed25519ll')
-rw-r--r--dev-python/ed25519ll/Manifest1
-rw-r--r--dev-python/ed25519ll/ed25519ll-0.6.ebuild32
-rw-r--r--dev-python/ed25519ll/metadata.xml15
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/ed25519ll/Manifest b/dev-python/ed25519ll/Manifest
new file mode 100644
index 000000000000..a12392fc46a6
--- /dev/null
+++ b/dev-python/ed25519ll/Manifest
@@ -0,0 +1 @@
+DIST ed25519ll-0.6.tar.gz 74782 SHA256 7b75b7e6f4c7e7c172229aa78b13436ca9834ef5893598b49c7163d7ba55adf9 SHA512 03d6e1985371698d2fee9627fa24cd724ae2ce8399f55ef9c88df7166ddf88c4b56abbbf7971eb2c8591a6d703b92fcd52f743ecb5752841849eea23eba0978d WHIRLPOOL 71c914795a7b4fbd047471bc1efdafa6a033bc8c7aa3a4f315bdec5772c0a58574b5bfe94082e7f7173ff053f5438f40276358e2644974144266973487252668
diff --git a/dev-python/ed25519ll/ed25519ll-0.6.ebuild b/dev-python/ed25519ll/ed25519ll-0.6.ebuild
new file mode 100644
index 000000000000..25c771582677
--- /dev/null
+++ b/dev-python/ed25519ll/ed25519ll-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A low-level ctypes wrapper for Ed25519 digital signatures."
+HOMEPAGE="http://bitbucket.org/dholth/ed25519ll/ http://pypi.python.org/pypi/ed25519ll"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+# https://bitbucket.org/dholth/ed25519ll/issues/1/testfailures-with-python-3
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/ed25519ll/metadata.xml b/dev-python/ed25519ll/metadata.xml
new file mode 100644
index 000000000000..eef113ad53e8
--- /dev/null
+++ b/dev-python/ed25519ll/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ed25519ll</remote-id>
+ <maintainer status="unknown">
+ <email>dholth@fastmail.fm</email>
+ <name>Daniel Holth</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>