summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:51:36 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:51:36 +0100
commite74092f463d25eeba8d438bedc24b48150ad6b37 (patch)
tree470187aeb9ffbbd0967c5446f458b228c3a7ee9e /dev-python/flask-mongoengine
parentdev-python/flask-migrate: Remove old (diff)
downloadgentoo-e74092f463d25eeba8d438bedc24b48150ad6b37.tar.gz
gentoo-e74092f463d25eeba8d438bedc24b48150ad6b37.tar.bz2
gentoo-e74092f463d25eeba8d438bedc24b48150ad6b37.zip
dev-python/flask-mongoengine: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/flask-mongoengine')
-rw-r--r--dev-python/flask-mongoengine/flask-mongoengine-0.9.3.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/flask-mongoengine/flask-mongoengine-0.9.3.ebuild b/dev-python/flask-mongoengine/flask-mongoengine-0.9.3.ebuild
deleted file mode 100644
index de2f0ea19122..000000000000
--- a/dev-python/flask-mongoengine/flask-mongoengine-0.9.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_5 )
-
-inherit distutils-r1
-
-RESTRICT="test" # requires running MongoDB server
-
-DESCRIPTION="Flask support for MongoDB and with WTF model forms"
-HOMEPAGE="https://pypi.org/project/flask-mongoengine/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/mongoengine-0.7.10[${PYTHON_USEDEP}]
- dev-python/flask-wtf[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # fix distutils sandbox violation due to missing test-deps in normal build
- sed -i '/test_requirements/d' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}