summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 21:45:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:27 -0500
commitd7a86f51278b6cd597d7abee70209d5c9072df81 (patch)
treed837d60280a991475a2ab1126cf4a901ee79b0e1 /dev-python/flask-restful/flask-restful-0.3.7.ebuild
parentdev-python/webob: 1.8.5 bump (diff)
downloadgentoo-d7a86f51278b6cd597d7abee70209d5c9072df81.tar.gz
gentoo-d7a86f51278b6cd597d7abee70209d5c9072df81.tar.bz2
gentoo-d7a86f51278b6cd597d7abee70209d5c9072df81.zip
dev-python/flask-restful: 0.3.7 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/flask-restful/flask-restful-0.3.7.ebuild')
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.7.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/flask-restful/flask-restful-0.3.7.ebuild b/dev-python/flask-restful/flask-restful-0.3.7.ebuild
new file mode 100644
index 000000000000..87d3f6c80bca
--- /dev/null
+++ b/dev-python/flask-restful/flask-restful-0.3.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple framework for creating REST APIs"
+HOMEPAGE="https://flask-restful.readthedocs.io/en/latest/ https://github.com/twilio/flask-restful/"
+SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc examples paging test"
+
+RDEPEND="
+ >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_compile_all() {
+ cd docs || die
+ emake man $(usex doc html "")
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
+
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}