summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-17 04:21:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-17 04:30:59 +0100
commitede13deaa7273ca0599a045d663cad06fd2a0f64 (patch)
tree4dba7748d00220ea24663730507c393b8c2a0958 /dev-python/flexmock
parentdev-python/paste: Bump to 3.8.0 (diff)
downloadgentoo-ede13deaa7273ca0599a045d663cad06fd2a0f64.tar.gz
gentoo-ede13deaa7273ca0599a045d663cad06fd2a0f64.tar.bz2
gentoo-ede13deaa7273ca0599a045d663cad06fd2a0f64.zip
dev-python/flexmock: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flexmock')
-rw-r--r--dev-python/flexmock/Manifest1
-rw-r--r--dev-python/flexmock/flexmock-0.12.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flexmock/Manifest b/dev-python/flexmock/Manifest
index fff180c05d39..c5a2768f05b0 100644
--- a/dev-python/flexmock/Manifest
+++ b/dev-python/flexmock/Manifest
@@ -1 +1,2 @@
DIST flexmock-0.11.3.tar.gz 52509 BLAKE2B 5246cedb3cae7aeb4ddee9158bc365be13bf81443711456a84abd3dfb30c8ea7cbca8fbce618efe26d33bc8185a9d7a52f1532934f7aad5fa11296ef21731963 SHA512 38387529d8b7e359cf6e578c9be8ae028cd28929567267bce1bb7f44032c00480520335315bb1c510229728e1101aa379b809fb89aeddafd19590e38e7ebdcf2
+DIST flexmock-0.12.0.tar.gz 52704 BLAKE2B fdae0ff50971359a9e27bb70173f10ee093d6dd9e5c70c893b7ef4392f6181472b7fbe6f6b277a1267032731cad9387d01af6e20eaddae42aab08ad4464032fb SHA512 2e0e1169b16c7fe6d251014fa7402aa8dfa8bda953d5e973d9f28964085556a8db9a3be84a37271878604f0d1b54f4c1da8af2d03e43cba9d4f2f8df3ba1f410
diff --git a/dev-python/flexmock/flexmock-0.12.0.ebuild b/dev-python/flexmock/flexmock-0.12.0.ebuild
new file mode 100644
index 000000000000..41a96f891538
--- /dev/null
+++ b/dev-python/flexmock/flexmock-0.12.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Testing library to create mocks, stubs and fakes"
+HOMEPAGE="https://flexmock.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_teamcity.py
+ tests/test_testtools.py
+ tests/test_unittest.py
+ )
+ epytest -p no:flaky
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}