summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-07 03:48:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-07 03:48:27 +0200
commit9aff08259e75b944771c0e39fc4b7bbb73e8a39e (patch)
treed0cce40e42437781bb3d0334468353625f291512 /dev-python/furo
parentdev-python/truststore: Bump to 0.9.1 (diff)
downloadgentoo-9aff08259e75b944771c0e39fc4b7bbb73e8a39e.tar.gz
gentoo-9aff08259e75b944771c0e39fc4b7bbb73e8a39e.tar.bz2
gentoo-9aff08259e75b944771c0e39fc4b7bbb73e8a39e.zip
dev-python/furo: Bump to 2024.5.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/furo')
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2024.5.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index 8873ea9d6786..fbfea5448a90 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1,2 +1,3 @@
DIST furo-2024.1.29-py3-none-any.whl 325212 BLAKE2B 7dec8d515bb2ac6741d875dac57048e066f6e9602e7c529bfcf5b01a8b47d6ff38d6212d5a5abf8dfbe42d7667481a3a14c20f39367d65d8968e429e6c5fbbea SHA512 375fff9ad283732c0e242da0233e6b3e5bc570c514fa1a5899232599ac1a73c3198071e74635ab115ba28ea9d97156e1c28ae40c5e203cc21cf639b183201893
DIST furo-2024.4.27-py3-none-any.whl 330359 BLAKE2B 4c6997cb8335cbaf9926cfb8d650edb0baec735858bb141e3a63d24e2bc48bdbaff504539aa449e4f76ca1890e987bdbaaf3e0e55f441e3a5c6467ed6dc94a6c SHA512 2790121eccde99771fe219d7d32887e243eafe87cfe3736cb26d9ae83190bbbe25fe629195f080df8632d51e1644cb142f6433f768e245c9ca0a44b25297279b
+DIST furo-2024.5.6-py3-none-any.whl 341199 BLAKE2B 6cecc3407bb91f096ba755d2d36f8e165dd8887f513495013533907017248c8a1f15d8019d5b4d5e7acd2793d95dc82cf95fc5ca1d9ad42bdcc57983d451db97 SHA512 932336ddff321b5dcdf98ee6aeda2cd33ce7981fb3f74fad5c2c732ff7d5be9c8666dd89808630a24b7d610965f8921ad477e9409ba5c2b9ad112d338dd06629
diff --git a/dev-python/furo/furo-2024.5.6.ebuild b/dev-python/furo/furo-2024.5.6.ebuild
new file mode 100644
index 000000000000..d306ea1caab9
--- /dev/null
+++ b/dev-python/furo/furo-2024.5.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}