summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 16:47:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 16:47:29 +0200
commitbe0b66c81444b9111703f1f602094bcebe6f5b5a (patch)
treefe85994935504729caf55e52ed8f5b11033b22f2 /dev-python/geventhttpclient
parentdev-python/gevent: Remove old (diff)
downloadgentoo-be0b66c81444b9111703f1f602094bcebe6f5b5a.tar.gz
gentoo-be0b66c81444b9111703f1f602094bcebe6f5b5a.tar.bz2
gentoo-be0b66c81444b9111703f1f602094bcebe6f5b5a.zip
dev-python/geventhttpclient: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.4.2.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 5cef6effc0c3..fc79f7d24ceb 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,2 +1 @@
-DIST geventhttpclient-1.4.2.tar.gz 57535 BLAKE2B f3c17140698b1609d9953110790fb536d982782c60165c717b6cee290c0b8fa5ae99cd6935401b6b617f0bd021783dd3f836c7cff775f513b9084714da1575a7 SHA512 3252d27f07a4642ba34d449664f50451b2ca4e44dc508345133d21acf659251a66be72784bacd312c074de4025dd5e080bdf35c84d9f7d40057132184a4d285d
DIST geventhttpclient-1.4.4.tar.gz 57620 BLAKE2B 20b60cfa7e8221b050bfd95a6e23c2f3eee87c0df1e93171719c7ba1804e88c918471cdd01cf4c6020fb6d44d0a1b911ee09dd44cc1e150b5d18d6052f2904cf SHA512 c6a8580707f3178a3a55eb638b9e3f36f82aecbd8a5ce044f0b8c167d88ad2bec584275bed6b720a5f7a546b0ffd113bec28dd2e1ff4290c60f0b5e13542b737
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.4.2.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.4.2.ebuild
deleted file mode 100644
index 248eb286dece..000000000000
--- a/dev-python/geventhttpclient/geventhttpclient-1.4.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
-HOMEPAGE="https://github.com/gwik/geventhttpclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Skip SNI tests which require dpkt
- sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local skipped_tests=(
- # Require dpkg
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
- )
- # Append to sys.path to avoid ImportError
- # https://bugs.gentoo.org/667758
- # Skip tests which require internet access
- pytest --import-mode=append -vv ${skipped_tests[@]/#/--deselect } \
- -m "not online" || die "Tests failed with ${EPYTHON}"
-}