summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-10 17:53:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-10 18:27:56 +0200
commitf7708e53672b008e63f7e10c63e63c09dae1c26e (patch)
tree8a0bfdc8604409e24354a5219771bc02a0d2559f /dev-python/griffe
parentdev-python/griffe: Remove old (diff)
downloadgentoo-f7708e53672b008e63f7e10c63e63c09dae1c26e.tar.gz
gentoo-f7708e53672b008e63f7e10c63e63c09dae1c26e.tar.bz2
gentoo-f7708e53672b008e63f7e10c63e63c09dae1c26e.zip
dev-python/griffe: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-1.3.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 7d6a6eb9019c..d5113e60291e 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-1.2.0.gh.tar.gz 382642 BLAKE2B a9db18e6cca59d85f8af61cde0fe5bf622d8804a6fa12d4128b4b52dbf8d7478b06aa5b746ce97cd3398550a926029fcc7096e5ae95f918e652a8295d9fb60e7 SHA512 334d4d08dfab5d8b24020e2901ab71a624478d1d84025123e85dc9ea6768bd51681788983c2328e2c9296fe36b9304512657577c7c12b6a6196363eb965b473d
+DIST griffe-1.3.0.gh.tar.gz 383337 BLAKE2B e1908e68f812b9227f4ba7249a8f20ae1d75cac3237ca90c5f47adb51a8d0efcd31b016f30f9f9e0af2a2292b86cf5fb08d9314e72ca4282bd36cafce19030ac SHA512 839d0bb8fc36f5552d50721f72905d533849d9b7258ba1ed1eabc783dddc4aee87ea612605bd23268f4282c06e71e010e76dfebce0951ef92917abc80211e7d1
diff --git a/dev-python/griffe/griffe-1.3.0.ebuild b/dev-python/griffe/griffe-1.3.0.ebuild
new file mode 100644
index 000000000000..b3ab8d048238
--- /dev/null
+++ b/dev-python/griffe/griffe-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/backports-strenum-1.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)